Bug #37967

YouTube videos can't be played with Media CE

Added by Lorenz Ulrich almost 8 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Content Rendering
Target version:
Start date:
2012-06-12
Due date:
% Done:

100%

TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since the rework of the Media CE for TYPO3 4.7, YouTube videos cannot be played anymore using the Media CE. The path to the video file is resolved correctly, but obviously the "TYPO3 Media Player" cannot play YouTube videos.

I compared the handling of 4.6 and 4.7 to get one step further in this problem:

- TYPO3 4.6 has a flag "Use Player (Flash only)". When this is checked, TYPO3 tries to play a video with the Flash Player.

- This "TYPO3 Media Player" (contrib/flashmedia/swfplayer.swf) cannot play YouTube videos.

- Unchecking the Player checkbox in 4.6 sets the YouTube/v URL itself as player (typo3\sysext\cms\tslib\content\class.tslib_content_media.php, l. 188). The YouTube player is correctly rendered then.

- The option to deactive the player is missing in TYPO3 4.7. Therefore the YouTube player itself will never be rendered and YouTube videos cannot be played with the Media element in 4.7.

I just googled about using the FlowPlayer to play YouTube videos. But obiously this is only possible with a commercial plugin (http://flowplayer.electroteque.org/youtube). So basically my conclusion would be that we need to have back the SWF rendering with the YouTube SWF as player.

Side note: Vimeo videos seem to work...

Associated revisions

Revision f8adef04 (diff)
Added by Kai Vogel almost 8 years ago

[BUGFIX] YouTube videos can not be played with Media CE

Since the rework of the media content element for TYPO3 4.7, YouTube
videos cannot be played anymore using the Media CE. This patch adds
an autodetection of urls which are handled by a media wizard and sets
correct video renderer type.

Tested with youtube, vimeo, myvideo, liveleak

Change-Id: I600d94eb60a7451873835142e2019ddfd39e8deb
Fixes: #37967
Releases: 6.0, 4.7
Reviewed-on: http://review.typo3.org/12782
Reviewed-by: Marcus Schwemer
Tested-by: Marcus Schwemer
Reviewed-by: Nikolas Hagelstein
Tested-by: Nikolas Hagelstein
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

Revision fc1a8f08 (diff)
Added by Kai Vogel almost 8 years ago

[BUGFIX] YouTube videos can not be played with Media CE

Since the rework of the media content element for TYPO3 4.7, YouTube
videos cannot be played anymore using the Media CE. This patch adds
an autodetection of urls which are handled by a media wizard and sets
correct video renderer type.

Tested with youtube, vimeo, myvideo, liveleak

Change-Id: I600d94eb60a7451873835142e2019ddfd39e8deb
Fixes: #37967
Releases: 6.0, 4.7
Reviewed-on: http://review.typo3.org/13004
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

Revision ef613093 (diff)
Added by Kai Vogel almost 8 years ago

[BUGFIX] YouTube videos can not be played with Media CE

Since the rework of the media content element for TYPO3 4.7, YouTube
videos cannot be played anymore using the Media CE. This patch adds
an autodetection of urls which are handled by a media wizard and sets
correct video renderer type.

Tested with youtube, vimeo, myvideo, liveleak

Change-Id: I600d94eb60a7451873835142e2019ddfd39e8deb
Fixes: #37967
Releases: 6.0, 4.7
Reviewed-on: http://review.typo3.org/12782
Reviewed-by: Marcus Schwemer
Tested-by: Marcus Schwemer
Reviewed-by: Nikolas Hagelstein
Tested-by: Nikolas Hagelstein
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

History

#1 Updated by Thomas Deinhamer almost 8 years ago

  • Target version set to 4.7.2

Just noticed this also. It's just impossible
to play a youtube video with the new media CE.

#2 Updated by Gerrit Code Review almost 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/12782

#3 Updated by Gerrit Code Review almost 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/12782

#4 Updated by Gerrit Code Review almost 8 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/13004

#5 Updated by Kai Vogel almost 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF