Bug #38293

Missing class definitions in core autoloader

Added by Oliver Hader over 7 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2012-06-22
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since the classes in typo3/ have been moved to the TYPO3 Core Autoloader as well and accordant require() calls removed, some parts of the TYPO3 Backend will show a PHP Fatal Error like "class not found". The reason is, that there are PHP files with multiple class definitions that have not been considered.

Examples:
  • Fatal error: Class 'browse_links' not found

Related issues

Related to TYPO3 Core - Task #38131: Remove require statements for classes Closed 2012-06-21

Associated revisions

Revision 60eb6ff3 (diff)
Added by Oliver Hader over 7 years ago

[BUGFIX] Missing class definitions in core autoloader

Since the classes in typo3/ have been moved to the TYPO3 Core
Autoloader as well and accordant require() calls removed, some
parts of the TYPO3 Backend will show a PHP Fatal Error like
"class not found".
The reason is, that there are PHP files with multiple class
definitions that have not been considered.

The changed autoload registry file was created with the SVN
version of EXT:extdeveval.

Change-Id: Id78e479ea51757eead7ec7298e8749c44d148ab0
Fixes: #38293
Releases: 6.0
Reviewed-on: http://review.typo3.org/12286
Reviewed-by: Philipp Gampe
Tested-by: Philipp Gampe
Reviewed-by: Helmut Hummel
Tested-by: Helmut Hummel

Revision 4d581e09 (diff)
Added by Oliver Hader over 7 years ago

[BUGFIX] Missing class definitions in core autoloader

Since the classes in typo3/ have been moved to the TYPO3 Core
Autoloader as well and accordant require() calls removed, some
parts of the TYPO3 Backend will show a PHP Fatal Error like
"class not found".
The reason is, that there are PHP files with multiple class
definitions that have not been considered.

The changed autoload registry file was created with the SVN
version of EXT:extdeveval.

Change-Id: Id78e479ea51757eead7ec7298e8749c44d148ab0
Fixes: #38293
Releases: 6.0
Reviewed-on: http://review.typo3.org/12286
Reviewed-by: Philipp Gampe
Tested-by: Philipp Gampe
Reviewed-by: Helmut Hummel
Tested-by: Helmut Hummel

History

#1 Updated by Gerrit Code Review over 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/12286

#2 Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/12286

#3 Updated by Oliver Hader over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF