Bug #38505

Reinstalling felogin throws errors

Added by Thomas Deinhamer almost 9 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
Start date:
2012-06-30
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I uninstalled and reinstalled felogin
and then I get this error in the frontend:

Uncaught TYPO3 Exception
#1303237468: Given select field item list was not found.

RuntimeException thrown in file
\t3lib\class.t3lib_extmgm.php in line 476.

5 t3lib_extMgm::addTcaSelectItem("tt_content", "CType", array, "mailform", "after")

I tried clearing all cache files etc.
but the error only goes away if I uninstall it.

This happens on windows, not sure
if it will also happen on linux.

#1

Updated by Thomas Deinhamer almost 9 years ago

K, this error comes up if I uninstall
css_styled_content; it seems the felogin
is more dependent on csc as I thought.

The problem in detail is, that "addTcaSelectItem"
tries to load the TCA for tt_content, but fails to
load the whole TCA, because before somewhere in
another extension, the TCA array is filled with
some configuration, without loading the whole
TCA before.

Meaning, "loadTCA" only loads the TCA, if the
TCA[$table] array is EMPTY, but if some extension
pre-populates TCA[$table] with any data, "loadTCA"
just won't load the default/whole TCA.

Thats why the code in "addTcaSelectItem" throws
an error - because the TCA['tt_content'] is available,
but the column 'CType' is not available inside it.

#2

Updated by Jigal van Hemert over 8 years ago

  • Category deleted (felogin)

CSS styled content does indeed TCA modifications for tt_content without loading the TCA for that table first.

#3

Updated by Jigal van Hemert over 8 years ago

  • Assignee set to Jigal van Hemert
#4

Updated by Gerrit Code Review over 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/17171

#5

Updated by Alexander Stehlik over 8 years ago

The same problem seems to occur for the form extension.

This extension also adds values to the TCA array but does not call loadTCA() before that.

Maybe this can be included in the pending patch?

#6

Updated by Alexander Stehlik over 8 years ago

After digging into this I figured out two things.

First: the problem is not caused by css_styled_content. At the beginning of it's ext_tables.php file it calls

\TYPO3\CMS\Core\Utility\ExtensionManagementUtility::addPiFlexFormValue('*', 'FILE:EXT:css_styled_content/flexform_ds.xml', 'table');

This calls \TYPO3\CMS\Core\Utility\GeneralUtility::loadTCA('tt_content'); at the beginning, so another loadTca() would be superfluous.

Second: The problem can only be reproduced, when the extensions are loaded in a defined order. Put this order into you LocalConfiguration.php file:

'form',
'css_styled_content',
'felogin',

Now you can clear all caches and reload your Frontend. You will see the exception.

#7

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/17171

#8

Updated by Gerrit Code Review over 8 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/17171

#9

Updated by Gerrit Code Review over 8 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/17171

#10

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/17940

#11

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/17941

#12

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at https://review.typo3.org/17942

#13

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at https://review.typo3.org/17943

#14

Updated by Jigal van Hemert over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#15

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF