Bug #38849

IRRE record can not be expaned in IE

Added by Andreas Kiessling about 10 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-07-10
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

A really weired error after upgrading to 4.5.17 which has to do with the fixed hide/unhide issue:

IE8 and 9 do not show any error after clicking the title to expand a record, but the details are not shown, only the spinner is active.
I could not reproduce it on a 4.7 setup what makes it even stranger, because the jsfunc.inline.js files seem to be identical in 4.5 and .47.

However, there seems to be a problem with the removal of the elements

    // It might be the case that a child record
    // cannot be hidden at all (no hidden field)
if (formObj.length && valueObj.length) {
    hiddenValue = formObj[0].checked;
    formObj[0].remove();
    valueObj[0].remove();
}

I needed to wrap formObj0 and valueObj0 in a $() so the prototype method is used here and not the DOM method.

    // It might be the case that a child record
    // cannot be hidden at all (no hidden field)
if (formObj.length && valueObj.length) {
    hiddenValue = formObj[0].checked;
    $(formObj[0]).remove();
    $(valueObj[0]).remove();
}

Prototype seems to not directly remove the element, but calls removeChild from the parentNode. Maybe this prevents IE in that case from crashing.

  remove: function(element) {
    element = $(element);
    element.parentNode.removeChild(element);
    return element;
  },

#1

Updated by Andreas Kiessling about 10 years ago

Missed a "d" in the subject...: IRRE record can not be expanded in IE

#2

Updated by Stefan Aebischer about 10 years ago

I could not reproduce it on a 4.7 setup what makes it even stranger, because the jsfunc.inline.js files seem to be identical in 4.5 and .47.

I can reproduce this bug in 4.7.2 and 4.5.17 on Internet Explorer 8

#3

Updated by Gerrit Code Review about 10 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/12776

#4

Updated by Gerrit Code Review about 10 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/12776

#5

Updated by Gerrit Code Review about 10 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/12776

#6

Updated by Gerrit Code Review about 10 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/13410

#7

Updated by Gerrit Code Review about 10 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/13411

#8

Updated by Gerrit Code Review about 10 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/13412

#9

Updated by Anonymous about 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#10

Updated by Gerrit Code Review almost 10 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/13678

#11

Updated by Helmut Hummel almost 10 years ago

  • Status changed from Under Review to Resolved
#12

Updated by Benni Mack almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF