Bug #39634

Solved Bug #34152 results in a new interpretation of my TypoScript

Added by Stefan Froemken about 7 years ago. Updated about 7 years ago.

Status:
Rejected
Priority:
Should have
Category:
TypoScript
Target version:
-
Start date:
2012-08-09
Due date:
% Done:

0%

TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

As Oliver Hader told me in TYPO3-Core-List "[TYPO3-core] Announcing TYPO3 4.5.18, 4.6.11 and 4.7.3" I created a new report regarding my problem here:

After updating from 4.6.10 -> 4.6.11 some links out of my TemplaVoila FCEs are not linked anymore. The working links direct to a wrong location. I have changed TYPO3-Source three time, so the problem is in the new core.

The field "uid" is not the "uid" of the select-part anymore. My TS returns following records:

224 Tceforms // not linked
225 Ctrl // not linked
69 fluid // not linked
14 Warum jQuery? // linked
2 Home // linked
255 Form // not linked
252 Buttons // not linked

But the Link "Home" shows to record "index.php?id=40" instead of "2"
and the link "Warum jQuery?" shows to record index.php?id=8" instead of "14"

Here is my TypoScript:

10 = CONTENT
10 {
    table = tt_content
    select {
        orderBy = MAX(tt_content.tstamp) DESC
        groupBy = tt_content.pid
        pidInList = 1
        recursive = 10
        max = 7
        where = nav_hide = 0
        selectFields = pages.uid, pages.title
        leftjoin = pages ON (tt_content.pid = pages.uid)
    }

    renderObj = TEXT
    renderObj {
      field = title
      required = 1
      typolink.parameter.field = uid // maybe here is the problem
      typolink.ATagParams = class=internal-link
      wrap = <li>|</li>
    }
    wrap = <h2>Meine zuletzt bearbeiteten Inhalte</h2><ul>|</ul>
}

It seems that there are problems with: tslib_cObj::sanitizeSelectPart()

Oliver tolds me to debug the params:

$selectPart: pages.uid, pages.title
$table: tt_content

Stefan

test_39634.diff View (624 Bytes) Michael Stucki, 2012-08-09 13:41


Related issues

Related to TYPO3 Core - Bug #34152: stdWrap function numRows() fails in 4.6 due to wrong SELECT clause Closed 2012-02-21

History

#1 Updated by Markus Klein about 7 years ago

This is not a bug, but rather wrong usage.

You never explicitly select uid.

Suggestion: Use typolink.parameter.field = tt_content.uid // maybe here is the problem instead.

#2 Updated by Michael Stucki about 7 years ago

The attached patch provides a test to reproduce this problem.

Update: Ignore the patch, it was wrong!

#3 Updated by Michael Stucki about 7 years ago

  • Status changed from New to Rejected
  • Assignee set to Michael Stucki

After discussion [1] it turns out that the behaviour is correct. The problem is just that the wrong code worked in the past but doesn't work any more.
The mistake is that in your example, you select "tt_content.title", whereas only "title" is used later in the typolink directive.

Therefore, this is not an issue and I am closing it.

[1] http://lists.typo3.org/pipermail/typo3-team-core/2012-August/052155.html

Also available in: Atom PDF