Bug #40152

Task #40095: Move core to namespaces

Error when accessing wizard module and wizard_create_pages is disabled

Added by Tymoteusz Motylewski over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-08-25
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When extension wizard module I've got error:

#1270853878: TYPO3 Fatal Error: Extension key "wizard_create_pages" is NOT loaded! (More information)

BadFunctionCallException thrown in file
typo3\sysext\core\Classes\Extension\ExtensionManager.php in line 89.

the cause of this error is mapping in
typo3\sysext\wizard_crpages\class.tx_wizardcrpages_webfunc_2.php

require_once \TYPO3\CMS\Core\Extension\ExtensionManager::extPath('wizard_create_pages') . 'Classes/Controller/CreatePagesWizardModuleFunctionController.php';

but wizard_create_pages is not real extension but just folder with one file


Related issues

Duplicates TYPO3 Core - Bug #40178: Namespace: Revert extension split-ups (wizard_crpages) Closed 2012-08-25

History

#1 Updated by Christian Kuhn over 7 years ago

  • Parent task set to #40095

#2 Updated by Steffen Gebert over 7 years ago

  • Status changed from New to Accepted

#3 Updated by Christian Kuhn over 7 years ago

  • Status changed from Accepted to Closed
  • % Done changed from 0 to 100

dupe of #40178

Also available in: Atom PDF