Bug #40155

Task #40095: Move core to namespaces

browse_links.php instantiates wrong class namespace

Added by Nico de Haen almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-08-25
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

typo3/browse_links.php contains:

makeInstance('SC_TYPO3\\CMS\\Recordlist\\Browser\\ElementBrowser');

which should be

makeInstance('TYPO3\\CMS\\Recordlist\\Browser\\ElementBrowser');

I suppose
and then there is a call to $OBE->main()
which causes a fatal error, since the ElementBrowser class does not have a method named main()

Parent task: #40095
(Can't access that field here in bugtracker)


Related issues

Is duplicate of TYPO3 Core - Bug #40203: Namespace: Element BrowserClosed2012-08-25

Actions
#1

Updated by Christian Kuhn almost 9 years ago

  • Parent task set to #40095
#2

Updated by Steffen Gebert almost 9 years ago

  • Status changed from New to Accepted
#3

Updated by Christian Kuhn almost 9 years ago

  • Status changed from Accepted to Closed
  • % Done changed from 0 to 100

fixed with #40203

Also available in: Atom PDF