Bug #40951

Task #40095: Move core to namespaces

Rename autoloader class

Added by Helmut Hummel about 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
Start date:
2012-09-16
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The Autoloader class should be renamed to ClassLoader and be moved to systext/core/Classes/Core


Related issues

Related to TYPO3 Core - Bug #40653: Namespace interfaces don't work for PHP version < 5.3.7 due to type hinting issuesClosed2012-09-05

Actions
#1

Updated by Helmut Hummel about 9 years ago

  • Parent task set to #40095
#2

Updated by Thomas Maroschik about 9 years ago

  • Status changed from New to Under Review
  • Assignee set to Thomas Maroschik
#3

Updated by Thomas Maroschik about 9 years ago

The change is already solved in the patch for #40653.

#4

Updated by Oliver Hader about 9 years ago

  • Status changed from Under Review to Closed

See #40653 and the patch there..

#5

Updated by Thomas Maroschik almost 9 years ago

  • % Done changed from 0 to 100

Also available in: Atom PDF