Bug #41165

Parameter $alternativeUrl not obeyed in t3lib_BEfunc::viewOnClick

Added by Kasper Ligaard over 8 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-09-20
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

In the method viewOnClick the parameter $alternativeUrl is documented like this: "$alternativeUrl is an alternative URL which - if set - will make all other parameters ignored: The function will just return the window.open command wrapped around this URL! The hook will allow modification, though."

But that is not obeyed anymore. The semantics of the method was inadvertently changed when a hook was added, see bug #22157. Rectifying the semantics while keeping the hook is luckily no problem.

The change needs to be done in TYPO3 4.4, 4.5, 4.6, 4.7 and 6.0.

PS: I first targeted this for 4.5, but since the change should also be in 6.0 I create this issue, since I couldn't find any way to modify the first issue, #41130.


Files

BackendUtility.php (177 KB) BackendUtility.php Kasper Ligaard, 2013-05-22 14:23

Related issues

Related to TYPO3 Core - Bug #41130: Parameter $alternativeUrl not obeyed in t3lib_BEfunc::viewOnClickClosed2012-09-20

Actions
#1

Updated by Gerrit Code Review over 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14826

#2

Updated by Alexander Opitz over 7 years ago

  • Target version deleted (6.0.0-RC1)
  • TYPO3 Version changed from 6.0 to 4.5

Hi can you rebase your patch to latest master?

#3

Updated by Kasper Ligaard over 7 years ago

Just to clarify:

1) I need to rebase against latest master, not latest 4.5?
2) Will the patch then also be applied to 4.4, 4.5, 4.6, 4.7, 6.0 and 6.1?

PS: I ask because it took three days work last time to jump through all the hoops to get this in, and noone reacted for 8 months. And I suspect it will take another 1-2 days to get this new patch ready (and I fear I have to do it against the new 6.x-series, which I will not waste time on, before a stable LTS release is out).
PPS: I am grateful You are looking into this issue. Thanks :-)

#4

Updated by Alexander Opitz over 7 years ago

Hi,

you should do this only against master. It will mostly be backported by the active developer team.

The patch will be applied/backported for 6.1, 6.0, 4.7 and 4.5 (all other versions aren't maintained any more).

If you wait till 6.2 LTS is released it is to late to include it in the release and hopefully we are faster this time to merge it. ;-)

BTW: You don't need to create a new issue, I'll update this one if needed.

#5

Updated by Kasper Ligaard over 7 years ago

I give up! Gerrit is the worst system I have ever tried.

I hope you will help me by getting the attached file into Gerrit. The file is correct against latest TYPO3v4 master.

#6

Updated by Alexander Opitz over 7 years ago

  • Status changed from Under Review to Needs Feedback
#7

Updated by Kasper Ligaard over 7 years ago

Yes and I don't want to fight with Gerrit anymore. Gerrit has created a gap which just makes it too difficult for people that are not regular core committers. I just simply refuse to use it anymore. It is a waste of my time.

You can close this issue, if you like. I really don't care anymore. Sorry.

#8

Updated by Alexander Opitz over 7 years ago

Hmmm, but you don't fight with gerrit you use normal git commands. So your problem seems more the usage of git.

Anyway, I take a look and will update.

#9

Updated by Kasper Ligaard over 7 years ago

Thanks. I really appreciate Your help :-)

#10

Updated by Gerrit Code Review over 7 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/14826

#11

Updated by Gerrit Code Review over 7 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/14826

#12

Updated by Gerrit Code Review over 7 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/14826

#13

Updated by Gerrit Code Review over 7 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/14826

#14

Updated by Gerrit Code Review over 7 years ago

Patch set 6 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/14826

#15

Updated by Gerrit Code Review over 7 years ago

Patch set 7 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/14826

#16

Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/22620

#17

Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/22621

#18

Updated by Anonymous over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#19

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF