Bug #41204

Preview images not rendered in Web > Page view on Windows systems

Added by Nicole Cordes about 8 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
Start date:
2012-09-21
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In Web > Page view the preview images are not rendered on Windows systems. Is is due to failing functions in class TYPO3\CMS\Core\Utility\PathUtility. Basically it's an issue with forward and backward slashes. In the class the constance DIRECTORY_SEPARATOR is used which is on Windows systems a backward slash. Normally paths in TYPO3 are converted to use forward slashes and here is the existing problem.


Related issues

Related to TYPO3 Core - Bug #39130: Uncaught Exception when accessing "Filelist" module - file in fileadmin, [windows] Closed 2012-07-20

Associated revisions

Revision d967075e (diff)
Added by Nicole Cordes about 8 years ago

[BUGFIX] Preview images not rendered in Web > Page view on Windows systems

In Web > Page view the preview images are not rendered on Windows systems.
This is due to failing functions in class
TYPO3\CMS\Core\Utility\PathUtility. Basically it's an issue with forward
and backward slashes. In the class the constance DIRECTORY_SEPARATOR is
used which is on Windows systems a backward slash. Normally paths in TYPO3
are converted to use forward slashes and here is the existing problem.

This patch removes the constance in some functions (which are nessessary
for preview images) and makes sure all pathes are converted to unix style.
Than processing can use forward shlashes and carry on.

Change-Id: If7b443e5180e26ceb089a5b47c1631c4c7eb21c1
Fixes: #41204
Releases: 6.0, 4.7
Reviewed-on: http://review.typo3.org/14873
Reviewed-by: Anja Leichsenring
Tested-by: Anja Leichsenring
Reviewed-by: Georg Ringer
Tested-by: Georg Ringer
Reviewed-by: Simon Schaufelberger
Tested-by: Simon Schaufelberger
Reviewed-by: Helmut Hummel
Tested-by: Helmut Hummel

Revision 5f59635a (diff)
Added by Nicole Cordes over 7 years ago

[BUGFIX] Preview images not rendered in Web > Page view on Windows systems

In Web > Page view the preview images are not rendered on Windows systems.
This is due to failing functions in class
TYPO3\CMS\Core\Utility\PathUtility. Basically it's an issue with forward
and backward slashes. In the class the constance DIRECTORY_SEPARATOR is
used which is on Windows systems a backward slash. Normally paths in TYPO3
are converted to use forward slashes and here is the existing problem.

This patch removes the constance in some functions (which are nessessary
for preview images) and makes sure all pathes are converted to unix style.
Than processing can use forward shlashes and carry on.

Change-Id: If7b443e5180e26ceb089a5b47c1631c4c7eb21c1
Fixes: #41204
Releases: 6.0, 4.7
Reviewed-on: https://review.typo3.org/17622
Reviewed-by: Mattias Nilsson
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

History

#1 Updated by Gerrit Code Review about 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14873

#2 Updated by Nicole Cordes about 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Riccardo De Contardi about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF