Bug #39130

Uncaught Exception when accessing "Filelist" module - file in fileadmin, [windows]

Added by Tymoteusz Motylewski over 7 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2012-07-20
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I'm getting "Uncaught TYPO3 Exception" when accessing Filelist module on Windows.
Seems that module breaks when there are files directly in fileadmin folder, files in other folders are displaying just fine.
I attached stack trace.

stacktrace.txt View (2.79 KB) Tymoteusz Motylewski, 2012-07-20 15:43


Related issues

Related to TYPO3 Core - Bug #41204: Preview images not rendered in Web > Page view on Windows systems Closed 2012-09-21

Associated revisions

Revision c0f83504 (diff)
Added by Nicole Cordes about 7 years ago

[BUGFIX] Uncaught Exception when accessing "Filelist" module in Windows

An Exception is thrown when files are found directly in fileadmin folder.
Because of a backslash a false identifier is generated and file cannot be
found anymore.

Change-Id: I6c9e8b56654dfb44ec33f697219b5299883e82c5
Fixes: #39130
Releases: 6.0
Reviewed-on: http://review.typo3.org/14514
Reviewed-by: Oliver Hader
Reviewed-by: Wouter Wolters
Reviewed-by: Simon Schaufelberger
Tested-by: Simon Schaufelberger
Tested-by: Oliver Hader

History

#1 Updated by Simon Schaufelberger over 7 years ago

same here. This happens only under fileadmin folder. All other subfolders are working well.

#2 Updated by Andreas Wolf over 7 years ago

  • Status changed from New to Needs Feedback

Are you using the auto-generated fileadmin mount? Maybe there's a problem with the way this one is created.

Apart from that, I spotted another error that should not be related to this bug - but you never know... See #40520 for more information.

#3 Updated by Andreas Wolf over 7 years ago

  • Project changed from File Abstraction Layer to TYPO3 Core

#4 Updated by Andreas Wolf over 7 years ago

  • Category set to File Abstraction Layer (FAL)
  • TYPO3 Version set to 6.0

#5 Updated by Simon Schaufelberger over 7 years ago

Andreas Wolf wrote:

Are you using the auto-generated fileadmin mount? Maybe there's a problem with the way this one is created.

Yes.

#6 Updated by Nicole Cordes about 7 years ago

Have the same issue. Debugging shows that identifier was created the wrong way. Backslashes are used on windows systems which have to be replaced. Upload a patch for that.

#7 Updated by Gerrit Code Review about 7 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14514

#8 Updated by Gerrit Code Review about 7 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14514

#9 Updated by Nicole Cordes about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#10 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF