Bug #41295

HTTP_Request2_CookieJar searches data in wrong directory

Added by Philipp Gampe about 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Backend API
Target version:
-
Start date:
2012-09-23
Due date:
% Done:

50%

TYPO3 Version:
4.6
PHP Version:
5.4
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

Solution: Move files


Related issues

Related to TYPO3 Core - Bug #32387: PEAR Problem with public-suffix-list.php Closed 2011-12-08
Related to TYPO3 Core - Task #48027: Update PEAR packages Closed 2013-05-07
Duplicates TYPO3 Core - Bug #37085: Included pear classes have no @data_dir@ set. Closed 2012-05-11

Associated revisions

Revision ec146457 (diff)
Added by Daniel Minder over 6 years ago

[TASK] Update PEAR packages

Update PEAR package HTTP_Request2 to version 2.1.1 and Net_URL2 to 2.0.0
so that TYPO3 contains the bug fixes contained in these releases.

Resolves: #48027
Resolves: #32387
Related: #37085
Related: #41295
Releases: 4.7, 6.0, 6.1, 6.2
Change-Id: I6795cae9857bdcb71272d9e68abb76bbc6d74fb8
Reviewed-on: https://review.typo3.org/20599
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn
Reviewed-by: Philipp Gampe
Tested-by: Philipp Gampe

Revision 5c69f743 (diff)
Added by Daniel Minder over 6 years ago

[TASK] Update PEAR packages

Update PEAR package HTTP_Request2 to version 2.1.1 and Net_URL2 to 2.0.0
so that TYPO3 contains the bug fixes contained in these releases.

Resolves: #48027
Resolves: #32387
Related: #37085
Related: #41295
Releases: 4.7, 6.0, 6.1, 6.2
Change-Id: I6795cae9857bdcb71272d9e68abb76bbc6d74fb8
Reviewed-on: https://review.typo3.org/20656
Reviewed-by: Philipp Gampe
Tested-by: Philipp Gampe

Revision 74888025 (diff)
Added by Daniel Minder over 6 years ago

[TASK] Update PEAR packages

Update PEAR package HTTP_Request2 to version 2.1.1 and Net_URL2 to 2.0.0
so that TYPO3 contains the bug fixes contained in these releases.

Resolves: #48027
Resolves: #32387
Related: #37085
Related: #41295
Releases: 4.7, 6.0, 6.1, 6.2
Change-Id: I6795cae9857bdcb71272d9e68abb76bbc6d74fb8
Reviewed-on: https://review.typo3.org/20657
Reviewed-by: Philipp Gampe
Tested-by: Philipp Gampe

Revision 98a980b2 (diff)
Added by Daniel Minder over 6 years ago

[TASK] Update PEAR packages

Update PEAR package HTTP_Request2 to version 2.1.1 and Net_URL2 to 2.0.0
so that TYPO3 contains the bug fixes contained in these releases.

Resolves: #48027
Resolves: #32387
Related: #37085
Related: #41295
Releases: 4.7, 6.0, 6.1, 6.2
Change-Id: I2ddb9805c06cb98ddbbfab9ee1dcb1237470737b
Reviewed-on: https://review.typo3.org/20658
Reviewed-by: Philipp Gampe
Tested-by: Philipp Gampe

History

#1 Updated by Gerrit Code Review about 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14966

#2 Updated by Philipp Gampe about 7 years ago

To test, run linkvalidator task with check for an external HTTP site (e.g. on Introduction package).

#3 Updated by Daniel Minder over 6 years ago

Is a duplicate of #37085. However, in this other issue there are patches for branches 4-6 and 4-7, which also need to be fixed.

Both solutions work, either moving the included files or changing the path in CookieJar. However, the fix that was applied to original PEAR has both. See http://svn.php.net/viewvc?view=revision&revision=318430 and http://svn.php.net/viewvc?view=revision&revision=318432 (only the change to CookieJar should be important here). So, one could also completely update to HTTP_Request2 2.1.1 - IMO this would be the best solution.

#4 Updated by Philipp Gampe over 6 years ago

Yes, an update would be best ... IMHO we could update even in lower branches, because the API is stable.

#5 Updated by Oliver Hader over 6 years ago

  • Status changed from Under Review to Closed

Closed in favor of issue #41295

#6 Updated by Daniel Minder over 6 years ago

? This issue, of which the number is 41295, is closed "in favor of issue #41295" ? Something seems to be wrong here!

Or do you mean #32387 instead since this refers to the same bug but is still open?

Anyway: I replaced in my live TYPO3 4.7 the PEAR package HTTP_Request2 with latest version 2.1.1 and PEAR package Net_URL2 with latest version 2.0.0. Works fine.

I could create a patch for 4.6, 4.7 and 6.0, but we should decide first to which issue it should be attached.

#7 Updated by Philipp Gampe over 6 years ago

@Daniel it would be cool if you could create a patch for the update. Just use this issue number.

#8 Updated by Florian Scholz over 6 years ago

Daniel Minder wrote:

Anyway: I replaced in my live TYPO3 4.7 the PEAR package HTTP_Request2 with latest version 2.1.1 and PEAR package Net_URL2 with latest version 2.0.0. Works fine.

I could create a patch for 4.6, 4.7 and 6.0, but we should decide first to which issue it should be attached.

Philipp Gampe wrote:

@Daniel it would be cool if you could create a patch for the update. Just use this issue number.

This is still a problem with the current TYPO3 6.0.4. What's the status here? Don't know why this ticket is closed...

#9 Updated by Daniel Minder over 6 years ago

I just create task #48027 for this issue and pushed patches for 4.7, 6.0, 6.1 and master.

#10 Updated by Philipp Gampe over 6 years ago

Please only push to master (or highest effected branch). Backports, including all patchsets, will be done by committer. It is too easy to miss a change done in a patchset if you push to other branches beforehand. Additionally, cherry-picking is easier than.

Also available in: Atom PDF