Bug #41770

Incomplete loaded CSS, white, blank page after login

Added by Peter Morgner almost 7 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2012-10-09
Due date:
% Done:

0%

TYPO3 Version:
4.7
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Like Bug #41463 i get a white, empty backend-page (also no source) after successfull login.
But the problem begins already with an incomplete loaded CSS on the login page. This happens on Windows 7 on all Browsers I use (Internet Explorer 9, Firefox 15.1, Safari, Iron 21.0.1200.0. In contrast to #41463 I get no errors. When I repeat loading the login mydomain.tld/typo3, more CSS styles come into effect, but not nearly all. By reloading mydomain.tld/typo3/backend.php nothing changes, it stays empty and changes from lightgray to white on the first reload.
Most remarkable circumstance is: Backend and Login are completely loaded when I switch to another computer (Win XP, same browsers like above). I tried to solve this by deleting the temp files in typo3conf, empty the caches, and reload the site - which did not help.

1_crashed_login.png View - Crashed login screen (21.1 KB) Peter Morgner, 2012-10-14 09:57

2_crashed_be.png View - Network tab from backend after login (38.6 KB) Peter Morgner, 2012-10-14 09:57

3_clear_compressed_files.png View - Trying to delete compressed files (13.2 KB) Peter Morgner, 2012-10-14 09:57

4_be_after_clearing.png View - Network tab after deleting compressor files (51.8 KB) Peter Morgner, 2012-10-14 09:57

History

#1 Updated by Vincent Mans almost 7 years ago

SORRY, I got it back... someone installed typo3viewportdemo years ago I guess...

I have the same issue. With differences: I do have source, and it worked well 2 days ago. It is blank/grey on Vista and Windows XP.

In this case it is an update from an older version, but it worked. Other installations with 4.7.4 work well.

I found these JS errors:

Uncaught TypeError: Cannot call method 'registerNavigationWidget' of undefined backend.php:136
Uncaught TypeError: Cannot read property 'ContentContainer' of undefined merged-c709eb40c5e508773dbcdbff8e76dcc2-7ba32113091367672d4cdba320e28567.js:2131
Uncaught TypeError: Cannot read property 'ModuleMenuContainer' of undefined merged-c709eb40c5e508773dbcdbff8e76dcc2-7ba32113091367672d4cdba320e28567.js:1885

#2 Updated by Steffen Gebert almost 7 years ago

  • Status changed from New to Needs Feedback
  • Priority changed from Must have to Should have

Vincent, yours is a different problem. Please file a new bug report, as yours seems to be a JS error.

Peter, could you please check, if all the CSS files referenced in the login page are accessible for the browser? You can use the Network tab of Firebug or Webkit (Chrome, Safari) Developer Tools.

Thanks for providing more information!

Steffen

#3 Updated by Peter Morgner almost 7 years ago

Steffen Gebert wrote:

Peter, could you please check, if all the CSS files referenced in the login page are accessible for the browser? You can use the Network tab of Firebug or Webkit (Chrome, Safari) Developer Tools.

Hi Steffen,
I really want to provide more, but since I logged on the backend via XP (where's all fine) and restarted the Win 7 Computer on the next day, it's all fine there again. But the problem will appear soon because it was not the first time. Of course I like to give you the required informations at this time.

Here are other complementary informations: I think it is a kind of caching (no browser caching) problem. When loading the backend was once stopped by some circumstance, it is then loaded again incomplete on next reload - on all browsers. Strangely, only on the computer where the whole process of loading went wrong once before (I did not forget to clear the browsercaches before reloading the backend, both computers are using the same IP)

Thank you!

#4 Updated by Peter Morgner almost 7 years ago

Hi Steffen,

now i've got some screenshots from the network tab.
Attachment 1 shows the crashed login screen (the way it begins).
Screenshot 2 is from backend/index.php, which was not loaded. The I tried to delete the compressor files, 16 files were left after this action (Screenshot 3). Then I reloaded backend index.php (Screenshot 4).

As you suspected most files are not loaded.
Thank you again.

#5 Updated by Heiko Nöthen almost 7 years ago

Peter Morgner wrote:

Hi Steffen,

now i've got some screenshots from the network tab.
Attachment 1 shows the crashed login screen (the way it begins).
Screenshot 2 is from backend/index.php, which was not loaded. The I tried to delete the compressor files, 16 files were left after this action (Screenshot 3). Then I reloaded backend index.php (Screenshot 4).

As you suspected most files are not loaded.
Thank you again.

Hi Peter,

i also had problems with one user who could not loggin to the backend. After i deleted all files in typo3temp the login worked. Towards a little investigation i found the reason: One of the locallang-BE-<hash>.js files was empty. The be_user priviously had a broken uc entry.

Hope this helps.

Greetings,
Heiko

#6 Updated by Peter Morgner almost 7 years ago

Hello Heiko,

I'll try this next time when my backend crashes again and will tell you about. Thank you very much for this hind. May be that it's advisable for me to stop the hashing of CSS and JS-Files.
But what I can not understand: I use two computers with the same IP at the same time, in the one the back end is shown completely - in the other I get the blank page. Only differences: One is a laptop with Win 7 I use with WLAN and the other a desktop computer with XP I use with LAN. But this can not be relevant - slowly I become superstitious.

#7 Updated by Peter Morgner almost 7 years ago

Heiko Nöthen wrote:

After i deleted all files in typo3temp the login worked.

I did this - only thing that changed was: the login was fully loaded, not the following backend-site.
I think there are working too many factors like different TS- or localconf-configurations, so this problem can't be solved in a simple way.

But now I've got another interesting thing:
I logged in with a different IP address (same time, same computer, but another browser using a proxy server) - it works!
Then i logged out and logged in via a browser with my normal IP: As usual, a crashed backend-page was shown. Then I deleted the browser cache, restarted my computer and uses my normal browser: it works!
Maybe this will help to find the reason.

#8 Updated by Peter Morgner almost 7 years ago

@Heiko Nöthen:
I really don't know why it did not work the first time, but you were right.

I think it's enough to delete all files in typo3temp/compressor (except .htaccess, if this file will be recreated automatically i don't know). Then I cleared the browser cache, and reloaded the backend (it was not necessary to log out before) via CTRL + R. This has now worked twice.

One additional fact is: Last time it happened, when i changed the computers - maybe this will help to fix this bug.

added @ 27.10.12
Sometimes it's necessary to reload the backend up to three times and more.

#9 Updated by Alexander Opitz about 6 years ago

Hi,

this issue is very old, does it still exists with newer versions of TYPO3 CMS (4.7 or 6.1)?

#10 Updated by Alexander Opitz almost 6 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

If you think, that this is the wrong decision, then please write to the mailing list typo3.teams.bugs with issue number and an explanation.

Also available in: Atom PDF