Feature #4190

Create a Demo task that's usefull in "real life"

Added by Ingo Renner over 11 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
scheduler
Target version:
-
Start date:
2009-08-08
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

Create a task that execute's once an hour, checks for the existance of the install tool enable file, and deletes it if it's older than an hour.

#1

Updated by Francois Suter over 11 years ago

There was a request from Lars Houmark to do this. I discussed with him and he was still interested in having this task, although he agreed that it was not as important now that there was this new mechanism for deleting the ENABLE_INSTALL_TOOL file. So I dropped this request. However if you want to go ahead with it, fine with me.

Should the task already be enabled when installing the scheduler? That would mean providing the extension with already a record in the database, like static tables. I don't really like this personnally. I think it's too "forceful".

About the deletion of the file: it should not be deleted if it's older than an hour, but when it's older than the task's periodicity. IMO.

#2

Updated by Francois Suter over 11 years ago

BTW Duplicate of #3308 (couldn't find it before...)

#3

Updated by Ingo Renner over 11 years ago

Francois Suter wrote:

There was a request from Lars Houmark to do this. I discussed with him and he was still interested in having this task, although he agreed that it was not as important now that there was this new mechanism for deleting the ENABLE_INSTALL_TOOL file. So I dropped this request. However if you want to go ahead with it, fine with me.

Will do, but as you said already, it's very low priority.

Should the task already be enabled when installing the scheduler? That would mean providing the extension with already a record in the database, like static tables. I don't really like this personnally. I think it's too "forceful".

Seems the same to me too.

About the deletion of the file: it should not be deleted if it's older than an hour, but when it's older than the task's periodicity. IMO.

If we do it, it should behave the same as the removal by the install tool itself IMO.

#4

Updated by Francois Suter over 11 years ago

About the deletion of the file: it should not be deleted if it's older than an hour, but when it's older than the task's periodicity. IMO.

If we do it, it should behave the same as the removal by the install tool itself IMO.

I thought this would give more flexibility to the admin. Of course, if the base mechanism is still active, it is pretty pointless to delete the file at another frequency than an hour. Otherwise it could be convienent I think.

#5

Updated by Georg Ringer over 9 years ago

i guess this can be closed, ENABLE_INSTALL_TOOL is automatically deleted if it is older than 1 hour

#6

Updated by Francois Suter over 9 years ago

  • Status changed from New to Closed

Indeed can be closed. There are several tasks packed with the Core since 4.5, including one in the Scheduler itself (caching framework garbage collection). There will be even more tasks with 4.6.

#7

Updated by Michael Stucki almost 7 years ago

  • Category set to scheduler
#8

Updated by Michael Stucki almost 7 years ago

  • Project changed from Scheduler to TYPO3 Core
  • Category changed from scheduler to scheduler

Also available in: Atom PDF