Bug #41938

Rename Log Interfaces "Writer" and "Processor" to "WriterInterface" and "ProcessorInterface"

Added by Steffen Müller almost 9 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Must have
Category:
Logging
Target version:
Start date:
2012-10-12
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When parsing the Logging API with the class parser for adding namespaces, the interfaces somehow got wrong names.

We have
  • "Writer" instead of "WriterInterface" in TYPO3\CMS\Core\Log\Writer and
  • "Processor" instead of "ProcessorInterface" in TYPO3\CMS\Core\Log\Processor

The interfaces should be renamed (including the filename) and get adapted in all classes which implement these interfaces.

IMHO this is a RC critical bug, because it will be a breaking change in future releases.


Related issues

Related to TYPO3 Core - Task #40095: Move core to namespacesClosed2012-08-232012-09-18

Actions
#1

Updated by Gerrit Code Review almost 9 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/15543

#2

Updated by Steffen Müller almost 9 years ago

Please mark this issue a sub-task of #40095

#3

Updated by Steffen Gebert almost 9 years ago

  • Assignee set to Steffen Gebert
  • Target version set to 6.0.0-RC1
#4

Updated by Steffen Müller almost 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Riccardo De Contardi almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF