Bug #42817

t3lib_iconworks::getIconImage for pages returns a broken image

Added by Simon Schaufelberger over 8 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-11-09
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

this code returns a broken image since it ends with a path instead of a file. this results in lots of broken images in lots of extensions like realurl in the info module.

t3lib_iconworks::getIconImage('pages',$row,$BACK_PATH);


Related issues

Related to TYPO3 Core - Bug #22706: t3lib_iconWorks::getIconImage is not needed anymoreClosedSteffen Ritter2010-05-24

Actions
Related to TYPO3 Core - Bug #23043: Not all getIconImage calls in Core are replaced by getSpriteIconForRecordClosedSteffen Ritter2010-06-29

Actions
#1

Updated by Wouter Wolters over 6 years ago

  • Status changed from New to Closed
  • Is Regression set to No

``IconUtility::getIconImage()`` is removed without replacement. Use sprite icon API instead.

Also available in: Atom PDF