Bug #43070

Forward uid to t3lib_BEfunc::getProcessedValue on creating differences

Added by Oliver Hader about 7 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Workspaces
Target version:
Start date:
2012-11-18
Due date:
% Done:

100%

Estimated time:
0.00 h
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The behaviour to show differences of records basically was copied from the history service.
Since the history only works on differences/deltas and not on fully stored records, no valid uid can be used.
However in the workspaces context each side (live version and workspace version) has a valid uid.
By forwarding this information to t3lib_BEfunc::getProcessedValue hooks can use this valuable data.

Associated revisions

Revision 98195290 (diff)
Added by Oliver Hader about 7 years ago

[BUGFIX] Forward uid to t3lib_BEfunc::getProcessedValue on creating differences

The behaviour to show differences of records basically was
copied from the history service. Since the history only works
on differences/deltas and not on fully stored records, no valid
uid can be used. However in the workspaces context each side
(live version and workspace version) has a valid uid.

By forwarding this data to t3lib_BEfunc::getProcessedValue,
hooks can use this valuable information.

Change-Id: Ifa1118eb84be8269e07618c4b35437d3762534e2
Fixes: #43070
Releases: 4.5, 4.6, 4.7, 6.0
Reviewed-on: http://review.typo3.org/16555
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision aae85efd (diff)
Added by Oliver Hader about 7 years ago

[BUGFIX] Forward uid to t3lib_BEfunc::getProcessedValue on creating differences

The behaviour to show differences of records basically was
copied from the history service. Since the history only works
on differences/deltas and not on fully stored records, no valid
uid can be used. However in the workspaces context each side
(live version and workspace version) has a valid uid.

By forwarding this data to t3lib_BEfunc::getProcessedValue,
hooks can use this valuable information.

Change-Id: Ifa1118eb84be8269e07618c4b35437d3762534e2
Fixes: #43070
Releases: 4.5, 4.6, 4.7, 6.0
Reviewed-on: http://review.typo3.org/16552
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision 276c38f2 (diff)
Added by Oliver Hader about 7 years ago

[BUGFIX] Forward uid to t3lib_BEfunc::getProcessedValue on creating differences

The behaviour to show differences of records basically was
copied from the history service. Since the history only works
on differences/deltas and not on fully stored records, no valid
uid can be used. However in the workspaces context each side
(live version and workspace version) has a valid uid.

By forwarding this data to t3lib_BEfunc::getProcessedValue,
hooks can use this valuable information.

Change-Id: Ifa1118eb84be8269e07618c4b35437d3762534e2
Fixes: #43070
Releases: 4.5, 4.6, 4.7, 6.0
Reviewed-on: http://review.typo3.org/16547
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision 54d529ad (diff)
Added by Oliver Hader about 7 years ago

[BUGFIX] Forward uid to t3lib_BEfunc::getProcessedValue on creating differences

The behaviour to show differences of records basically was
copied from the history service. Since the history only works
on differences/deltas and not on fully stored records, no valid
uid can be used. However in the workspaces context each side
(live version and workspace version) has a valid uid.

By forwarding this data to t3lib_BEfunc::getProcessedValue,
hooks can use this valuable information.

Change-Id: Ifa1118eb84be8269e07618c4b35437d3762534e2
Fixes: #43070
Releases: 4.5, 4.6, 4.7, 6.0
Reviewed-on: http://review.typo3.org/16549
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

History

#1 Updated by Gerrit Code Review about 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch 4.5 has been pushed to the review server.
It is available at http://review.typo3.org/16547

#2 Updated by Gerrit Code Review about 7 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16549

#3 Updated by Gerrit Code Review about 7 years ago

Patch set 1 for branch 4.6 has been pushed to the review server.
It is available at http://review.typo3.org/16552

#4 Updated by Gerrit Code Review about 7 years ago

Patch set 1 for branch workspaces_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/16555

#5 Updated by Gerrit Code Review about 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16549

#6 Updated by Oliver Hader about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Applied in changeset commit:ded872d55854fe1fe93b399225280e4ff7b48aa3.

#7 Updated by Michael Stucki about 6 years ago

  • Category changed from Bugs to Workspaces

#8 Updated by Michael Stucki about 6 years ago

  • Project changed from Workspaces & Versioning to TYPO3 Core
  • Category changed from Workspaces to Workspaces

#9 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF