Bug #44879

Remove inline styles from parsed blockquote tag

Added by Sebastian Michaelsen almost 7 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Content Rendering
Target version:
Start date:
2013-01-28
Due date:
% Done:

100%

TYPO3 Version:
6.1
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

css_styled_content's lib.parseFunc_RTE has the following rule:

externalBlocks.blockquote.callRecursive.tagStdWrap.HTMLparser.tags.blockquote.overrideAttribs = style="margin-bottom:0;margin-top:0;"

I don't know the intention of this rule (it's there since at least 20041) but it ruins my output as it removes my attributes (such as class) from blockquote tags and sets the inline styles instead - those should be avoided anyway.
So my suggestion is to simply remove this rule.

[1] http://git.typo3.org/TYPO3v4/Core.git/blob/5d4f9d2afe09d576075726f348d236409be896a0:/typo3/sysext/css_styled_content/static/setup.txt

Associated revisions

Revision 77ed0522 (diff)
Added by Jan Helke almost 5 years ago

[BUGFIX] Remove inline styles from parsed blockquote tag

When passing blockquote tags trough lib.parseFunc_RTE (this
is commonly done when rendering TS objects in Fluid templates)
their attributes will be replaced with some inline styles.
I don't know what the intention of this behavior is, but it's been
like this at least since 2004. Inline styles should generally be
avoided.
I suggest to simple remove this rule.

Code to reproduce the issue and test the change:
https://gist.github.com/4654874

Resolves: #44879
Releases: master
Change-Id: If8954fa392b906d78a8cc32aba9e5b23d84decd9
Reviewed-on: http://review.typo3.org/17758
Reviewed-by: Steffen Müller <>
Tested-by: Steffen Müller <>
Reviewed-by: Jan Helke <>
Tested-by: Jan Helke <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision 78e25bf4 (diff)
Added by Steffen Müller almost 5 years ago

[FOLLOW-UP] Remove inline styles from parsed blockquote tag

Add document about breaking changes to changelog

Resolves: #44879
Releases: master
Change-Id: I27ace3040a71d073f474d4ed12539fb56a6b7c1b
Reviewed-on: http://review.typo3.org/36561
Reviewed-by: Steffen Müller <>
Tested-by: Steffen Müller <>

History

#1 Updated by Gerrit Code Review almost 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/17758

#2 Updated by Gerrit Code Review almost 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/17758

#3 Updated by Gerrit Code Review almost 7 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/17758

#4 Updated by Dominik Lenné over 5 years ago

Issue holds for v 6.2.0

#5 Updated by Gerrit Code Review almost 5 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/17758

#6 Updated by Jan Helke almost 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF