Bug #45084

Strange <//span> tag when copying from ms word document

Added by Dimitri Koenig almost 9 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2013-02-01
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi there

Within my ms word document i have a list which, when copying to typo3, gets malformed with strange .
When i copy it into an rte from TYPO3 4.5.16 it works.

Text within another RTE:

<li class=MsoNormal style="MARGIN: 0cm 0cm 10pt; LINE-HEIGHT: 15pt; mso-margin-top-alt: auto; mso-margin-bottom-alt: auto; mso-list: l0 level1 lfo1; tab-stops: list 36.0pt"><span style="mso-bookmark: _GoBack"><span lang=DE style="FONT-SIZE: 12pt; FONT-FAMILY: 'Times New Roman','serif'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: DE; mso-fareast-language: DE">Test<o:p></o:p></span></span></li></ul>

Again another RTE:

<LI class=MsoNormal style="MARGIN: 0cm 0cm 10pt; LINE-HEIGHT: 15pt; mso-margin-top-alt: auto; mso-margin-bottom-alt: auto; mso-list: l0 level1 lfo1; tab-stops: list 36.0pt"><SPAN style="mso-bookmark: _GoBack"><SPAN lang=DE style="FONT-SIZE: 12pt; FONT-FAMILY: 'Times New Roman','serif'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: DE; mso-fareast-language: DE">Test</SPAN></SPAN></LI>

RTE 4.7.7 before saving:

"><li style="MARGIN: 0cm 0cm 10pt; LINE-HEIGHT: 15pt; mso-margin-top-alt: auto; mso-margin-bottom-alt: auto; mso-list: l0 level1 lfo1; tab-stops: list 36.0pt" class="MsoNormal"><span lang="DE">Test</span></span><//span></li>

RTE 4.7.7 after saving:

"><li style="MARGIN: 0cm 0cm 10pt; LINE-HEIGHT: 15pt; mso-margin-top-alt: auto; mso-margin-bottom-alt: auto; mso-list: l0 level1 lfo1; tab-stops: list 36.0pt" class="MsoNormal">Länge mindestens 6 und maximal 16 Zeichen</span><//span></span><//span>&lt;//span&gt;</li>

Any solutions?


Related issues

Is duplicate of TYPO3 Core - Bug #50144: HTMLParser does not remove end tag when applying rmTagIfNoAttribClosedStanislas Rolland2013-07-18

Actions
#1

Updated by Stanislas Rolland over 8 years ago

  • Status changed from New to Under Review

I think this is related to issue #50144.

Please test this change: https://review.typo3.org/#/c/22681/

#2

Updated by Mathias Schreiber almost 7 years ago

  • Is Regression set to No

Any news here?

#3

Updated by Stanislas Rolland almost 7 years ago

  • Status changed from Under Review to Closed

Closing as duplicate.

Also available in: Atom PDF