Project

General

Profile

Actions

Bug #45383

closed

Rendering of TIFF images broken

Added by Aske Ertmann over 11 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2013-02-11
Due date:
% Done:

50%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

Since FAL was introduced in 6.0 the rendering of TIFF images seems to have been broken. This is due to the fact that the image processing is not converting the TIFF image to a web supported format. I've checked in version 4.7 and there TIFF images and probably other non web supported formats are converted to PNG. The problem goes even further than not converting it to the correct format, since it actually creates a cropped file and then renames that to a new file name with a wrong file extension.

The problem is a combination of things in "TYPO3\CMS\Core\Resource\Processing\LocalCropScaleMaskHelper" (#79) which creates the configuration sent to "TYPO3\\CMS\\Frontend\\Imaging\\GifBuilder", "TYPO3\CMS\Core\Resource\Processing\AbstractGraphicalTask" which hardcodes the target file name extension to "jpg" or "png" (#62) and "TYPO3\CMS\Core\Resource\Processing\LocalImageProcessor" which renames the processed file to the new target filename (#84).


Related issues 1 (0 open1 closed)

Has duplicate TYPO3 Core - Bug #46530: Crop-Scaled images have wrong file content typeClosed2013-03-292013-03-29

Actions
Actions #1

Updated by Gerrit Code Review over 11 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18206

Actions #2

Updated by Gerrit Code Review over 11 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18206

Actions #3

Updated by Steffen Ritter over 11 years ago

  • Category changed from Image Cropping to File Abstraction Layer (FAL)
Actions #4

Updated by Steffen Ritter over 11 years ago

  • Status changed from Under Review to Resolved
Actions #5

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF