Bug #45398

rtehtmlarea remove blockstyle does not work

Added by Christian Bernet over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2013-02-12
Due date:
% Done:

0%

TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

The removing of the blockstyle does not work.
If i remove the csc-frame-frame1 in the typical configuration from the manual, the csc-frame-frame1 still will be showed in the backend.

Configuration without csc-frame-frame1
  1. Restrict the list of class selectors presented by the RTE to the following for the specified tags:
    buttons.blockstyle.tags.div.allowedClasses (
    align-left, align-center, align-right,
    csc-frame-frame2
    )

History

#1 Updated by Patrick Broens over 6 years ago

  • Status changed from New to Needs Feedback
  • Complexity set to easy

I cannot reproduce this. When I'm adding a blockstyle, I can remove it, before and after I save the content element.

Are you sure you selected the right block? What does the path say at the bottom of rtehtmlarea? Is that the block and is the class displayed with it (It should mention something like "ยป p.csc-frame-frame1"). Otherwise it might be you're selecting a block which is inside/outside of the block you want to select.

Could you please have a look? If the problem persists, it might be helpful to mention your OS, browser, browser version etc.

#2 Updated by Christian Bernet over 6 years ago

Thanks for your feedback. We checked this again an it works correct! Sorry.
Please close this issue.

Christian

#3 Updated by Andreas Wolf over 6 years ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF