Bug #45588

Fatal error: Class '\FE_loadDBGroup' not found in /typo3/sysext/core/Classes/Utility/GeneralUtility.php on line 4158

Added by Thomas Deinhamer over 8 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Content Rendering
Target version:
Start date:
2013-02-19
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When using an 'insert records' content element on a page I get the mentioned error:

Fatal error: Class '\FE_loadDBGroup' not found in .../typo3/sysext/core/Classes/Utility/GeneralUtility.php on line 4158

The missing class is in the file class.tslib_pagegen.php and is called
in the class \TYPO3\CMS\Frontend\ContentObject\RecordsContentObject on line 63:

$loadDB = \TYPO3\CMS\Core\Utility\GeneralUtility::makeInstance('FE_loadDBGroup');

There seems to be a second call in class \TYPO3\CMS\Frontend\ContentObject\Menu\AbstractMenuContentObject on line 500:

$loadDB = \TYPO3\CMS\Core\Utility\GeneralUtility::makeInstance('FE_loadDBGroup');

Should this class also be namespaced and called like that?

$loadDB = \TYPO3\CMS\Core\Utility\GeneralUtility::makeInstance('\TYPO3\CMS\Frontend\Page\...');

Thanks!


Related issues

Related to TYPO3 Core - Bug #23977: FE classes TSpagegen and FE_LoadDBgroup are not following naming conventionsClosedThorsten Kahler2010-11-07

Actions
#1

Updated by Thomas Deinhamer over 8 years ago

Okay, I actually changed some lines without using the class at all.

Changed

$loadDB = \TYPO3\CMS\Core\Utility\GeneralUtility::makeInstance('FE_loadDBGroup');
$loadDB->start($source, $allowedTables);

to

$loadDB = \TYPO3\CMS\Core\Utility\GeneralUtility::makeInstance('TYPO3\\CMS\\Core\\Database\\RelationHandler');
$loadDB->fromTC = 0;
$loadDB->start($source, $allowedTables);

in class \TYPO3\CMS\Frontend\ContentObject\RecordsContentObject on line 63-65.

Setting fromTC to 0, because that's the only purpose of the class FE_loadDBGroup, if I understood that correctly -
and now the insert records is displayed again without the error mentioned above.

#2

Updated by Georg Ringer over 8 years ago

  • Status changed from New to Resolved
  • Target version changed from 6.0.3 to 6.1.0
  • % Done changed from 0 to 100

resolved with #45937

#3

Updated by Riccardo De Contardi almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF