Bug #45606

Forms: Mail-Layout destroyed

Added by move:elevator no-lastname-given over 9 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
Start date:
2013-02-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When a form-layout is adapted by custom wraps, there are errors in the sent e-mail. The same problems occur on the "confirmation page" where the user can see what he entered.

example TS-Setup:

tt_content.mailform.20 {
    stdWrap.wrap = <div class="meFormWrapper mailForm floatFull">|</div>
    layout {
        containerWrap (
            <div class="textInputsWrap floatFull">
                <elements />
            </div>
        )
        elementWrap (
            <div class="meFormRow floatFull">
                <element />
            </div>
        )
        mandatory (
           <span class="required blueText">
             <mandatoryvalue />
           </span>
        )
        error (
            <span class="formError floatRight error">
              <errorvalue />
            </span>
        )
        textline (
            <div class="meFormRow floatFull">
                <label />
                <input />
            </div>
        )
        textarea (
            <div class="meFormRow floatFull">
                <label />
                <textarea />
            </div>
        )
        checkbox (
            <div class="meFormRow floatFull checkBox">
                <div class="checkBoxWrap">
                      <span class="checkBoxElem">
                          <input />
                            <label/>
                      </span>
                </div>
            </div>
        )
    }
}


Related issues

Related to TYPO3 Core - Bug #31951: Own checkbox layout breaks HTML mailClosed2011-11-20

Actions
#1

Updated by Jan Loderhose over 8 years ago

I can confirm this issue. I use

[...]
layout {
    checkbox (
        <input />
        <label />
    )
}
[...]

in a form config to switch the order of labels and checkboxes. This results in

[...]
<tr class=3D"csc-form-33 =
csc-form-element csc-form-element-checkbox">
          <input/>
 =
         <em>Some secret label text</e=
m>
        </tr>
[...]

Note the <input /> in the above snippet.

Edit: I use TYPO3 6.1.7

#2

Updated by Felix Nagel over 8 years ago

This issue seems to be related: #31951

#3

Updated by Felix Nagel almost 8 years ago

Fixed by: #31951 (at least for TYPO3 6.2.4)

#4

Updated by Christian Kuhn over 7 years ago

  • Status changed from New to Closed
  • Is Regression set to No

Seems to be fixed. Closed.

Also available in: Atom PDF