Bug #45777

Moving a file to another file storage throws fatal error

Added by Klaus Weidenbach over 9 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Must have
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2013-02-23
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Moving files between folders in the same File Storage works, but when you move a file to another File Storage there comes following error message:
Fatal error: Call to a member function getIdentifier() on a non-object in /.../typo3/sysext/core/Classes/Utility/File/ExtendedFileUtility.php on line 571

I have TYPO3 CMS 6.0.2 and both File Storages use the local filesystem driver.


Related issues

Is duplicate of TYPO3 Core - Bug #46564: Copy between different storages leads to copy in source storageClosed2013-03-22

Actions
#1

Updated by Alexander Opitz over 9 years ago

  • Assignee set to Alexander Opitz

Copying and moving files between storages isn't implemented yet. With #46564 an error message will be shown.

#2

Updated by Nicole Cordes over 9 years ago

  • Status changed from New to Resolved
#3

Updated by Benni Mack almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF