Bug #46564

Copy between different storages leads to copy in source storage

Added by Nicole Cordes about 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2013-03-22
Due date:
% Done:

100%

TYPO3 Version:
6.1
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If you try to copy a folder from one storage into another one it leads to a copy in the same (source) storage. This happens because the action is executed in the source storage and only works with the source folder object.

Besides the copyFolderBetweenStorages function raises an exception which might can be moved into the driver class as the driver should be responsable for the copy work. Therefore the AbstractDriver should support (abstract) methods to copy a folder between storages and the local driver should raises the exception.

Same applies to move folders between storages.


Related issues

Duplicated by TYPO3 Core - Bug #45777: Moving a file to another file storage throws fatal error Closed 2013-02-23

Associated revisions

Revision a9538cdb (diff)
Added by Nicole Cordes about 7 years ago

[BUGFIX] Copy and move folders between storages is broken

If you try to copy a folder from one storage into another one it leads to
a copy in the same (source) storage. This happens because the action is
executed in the source storage and only works with the source folder
object. This is fixed by calling the move method on the target storage
instead.

Besides the copyFolderBetweenStorages function raises an exception which
might be moved into the driver class as the driver should be responsible
for the copy work. Therefore the AbstractDriver should support
(abstract) methods to copy a folder between storages and the local
driver should raises the exception.

Same applies for moving folders between storages.

Change-Id: Ib282e351f39abca21d57f5d621b4bd999f8419d9
Fixes: #46564
Releases: 6.1, 6.0
Reviewed-on: https://review.typo3.org/19194
Reviewed-by: Andreas Wolf
Tested-by: Andreas Wolf

Revision 6e7769ca (diff)
Added by Nicole Cordes about 7 years ago

[BUGFIX] Copy and move folders between storages is broken

If you try to copy a folder from one storage into another one it leads to
a copy in the same (source) storage. This happens because the action is
executed in the source storage and only works with the source folder
object. This is fixed by calling the move method on the target storage
instead.

Besides the copyFolderBetweenStorages function raises an exception which
might be moved into the driver class as the driver should be responsible
for the copy work. Therefore the AbstractDriver should support
(abstract) methods to copy a folder between storages and the local
driver should raises the exception.

Same applies for moving folders between storages.

Change-Id: Ib282e351f39abca21d57f5d621b4bd999f8419d9
Fixes: #46564
Releases: 6.1, 6.0
Reviewed-on: https://review.typo3.org/19213
Reviewed-by: Benjamin Mack
Tested-by: Benjamin Mack

History

#1 Updated by Gerrit Code Review about 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19194

#2 Updated by Gerrit Code Review about 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19194

#3 Updated by Gerrit Code Review about 7 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19194

#4 Updated by Nicole Cordes about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Gerrit Code Review about 7 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/19213

#6 Updated by Nicole Cordes about 7 years ago

  • Status changed from Under Review to Resolved

#7 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF