Bug #45834

Detection of curlProxyServer settings buggy on upgrade to 6.0

Added by Ernesto Baschny over 6 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-02-25
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In #28344 "HTTP Request2" API was included. It supports detecting old school "curlProxyServer" settings and transfer these to the "new" setting under HTTP:

    $proxyParts = explode(':', $GLOBALS['TYPO3_CONF_VARS']['SYS']['curlProxyServer'], 2);
    $GLOBALS['TYPO3_CONF_VARS']['HTTP']['proxy_host'] = $proxyParts[0];
    $GLOBALS['TYPO3_CONF_VARS']['HTTP']['proxy_port'] = $proxyParts[1];

This code ended up in Core/Bootstrap::transferDeprecatedCurlSettings() after namespace and bootstrapification.

I have always set up this setting like this:

$GLOBALS['TYPO3_CONF_VARS']['SYS']['curlProxyServer'] = 'http://proxy:3128';

I guess the implementator of the transferDeprecatedCurlSettings was only thinking about the "proxy:3128" kind of syntax. I end up with:

$GLOBALS['TYPO3_CONF_VARS']['HTTP']['proxy_host'] = 'http'
$GLOBALS['TYPO3_CONF_VARS']['HTTP']['proxy_port'] = '//proxy:3128;

Other than that, I would also auto-set ['HTTP']['adapter'] to 'curl' if legacy 'curlUse' = TRUE.


Related issues

Related to TYPO3 Core - Feature #28344: Include HTTP Request2 for better HTTP handling Closed 2011-07-20 2011-07-25
Related to TYPO3 Core - Task #50506: Introduce use-statement for Utility-namespace in Bootstrap Closed 2013-07-29
Related to TYPO3 Core - Task #60622: Deprecate getUrl, curlProxyServer and encourage usage of HTTPRequest Rejected 2014-07-27

Associated revisions

Revision c85b2c43 (diff)
Added by Dmitry Dulepov about 6 years ago

[BUGFIX] Detection of curlProxyServer settings is incorrect

Parsing of 'curlProxyServer' option during the bootstrap is incorrect.
It produces wrong host and port part in 'proxy_host' and 'proxy_port'
system options.

Change-Id: I12f66acef697dbec9b065edcba8ad0d8f78c4e01
Resolves: #45834
Releases: 6.2, 6.1, 6.0
Reviewed-on: https://review.typo3.org/18481
Reviewed-by: Stefan Neufeind
Tested-by: Stefan Neufeind
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters

Revision efb08f73 (diff)
Added by Dmitry Dulepov about 6 years ago

[BUGFIX] Detection of curlProxyServer settings is incorrect

Parsing of 'curlProxyServer' option during the bootstrap is incorrect.
It produces wrong host and port part in 'proxy_host' and 'proxy_port'
system options.

Change-Id: I12f66acef697dbec9b065edcba8ad0d8f78c4e01
Resolves: #45834
Releases: 6.2, 6.1, 6.0
Reviewed-on: https://review.typo3.org/22650
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters

Revision ad4742ca (diff)
Added by Dmitry Dulepov about 6 years ago

[BUGFIX] Detection of curlProxyServer settings is incorrect

Parsing of 'curlProxyServer' option during the bootstrap is incorrect.
It produces wrong host and port part in 'proxy_host' and 'proxy_port'
system options.

Change-Id: I12f66acef697dbec9b065edcba8ad0d8f78c4e01
Resolves: #45834
Releases: 6.2, 6.1, 6.0
Reviewed-on: https://review.typo3.org/22651
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters

Revision 8730038f (diff)
Added by Stefan Neufeind about 6 years ago

[TASK] Introduce use-statement for Utility-namespace in Bootstrap

Change I12f66acef697dbec9b065edcba8ad0d8f78c4e01 broke
Bootstrap.php since there was no use-statement for the Utility-
namespace as we have in 6.1/6.2 already.

Introducing this use and shortening function-calls.

Change-Id: Idc6524d0b3b4c8c077ab00d21716dda5a2c04f0f
Related: #45834
Resolves: #50506
Releases: 6.0
Reviewed-on: https://review.typo3.org/22654
Tested-by: Stefan Neufeind
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters

Revision 3dd60e20 (diff)
Added by Ernesto Baschny about 5 years ago

[BUGFIX] Transfer curlProxyServer to new HTTP settings

Splits up the old curlProxyServer correctly, stripping "http://" and
potentially trailing slashes.

Resolves: #45834
Releases: 6.3, 6.2, 6.1
Change-Id: Ibfefb927b5fd3fe900170870e1093027d4fe34b5
Reviewed-on: http://review.typo3.org/31867
Reviewed-by: Stefan Neufeind <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

Revision f41086b7 (diff)
Added by Ernesto Baschny almost 5 years ago

[BUGFIX] Transfer curlProxyServer to new HTTP settings

Splits up the old curlProxyServer correctly, stripping "http://" and
potentially trailing slashes.

Resolves: #45834
Releases: 6.3, 6.2, 6.1
Change-Id: Ibfefb927b5fd3fe900170870e1093027d4fe34b5
Reviewed-on: http://review.typo3.org/31879
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

Revision ca5de2e9 (diff)
Added by Ernesto Baschny almost 5 years ago

[BUGFIX] Transfer curlProxyServer to new HTTP settings

Splits up the old curlProxyServer correctly, stripping "http://" and
potentially trailing slashes.

Resolves: #45834
Releases: 6.3, 6.2, 6.1
Change-Id: Ibfefb927b5fd3fe900170870e1093027d4fe34b5
Reviewed-on: http://review.typo3.org/31880
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

History

#1 Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18481

#2 Updated by Gerrit Code Review over 6 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18481

#3 Updated by Gerrit Code Review about 6 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18481

#4 Updated by Gerrit Code Review about 6 years ago

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/22650

#5 Updated by Gerrit Code Review about 6 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/22651

#6 Updated by Anonymous about 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Ernesto Baschny about 5 years ago

  • Status changed from Resolved to Accepted
  • Is Regression set to No

This problem is not really resolved yet. I still get:

$GLOBALS['TYPO3_CONF_VARS']['HTTP']['proxy_host'] = 'http://proxy'
$GLOBALS['TYPO3_CONF_VARS']['HTTP']['proxy_port'] = '3128/;

which is equally wrong. I wonder how the patch that ended up in the core was tested??

#8 Updated by Gerrit Code Review about 5 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31867

#9 Updated by Gerrit Code Review about 5 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31879

#10 Updated by Gerrit Code Review about 5 years ago

Patch set 1 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31880

#11 Updated by Ernesto Baschny about 5 years ago

  • Status changed from Under Review to Resolved

#12 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF