Bug #46007

Downloads with Whitespaces in Foldername fails after Migrate

Added by Henrik Ziegenhain over 9 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2013-03-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In the past download links set via RTE are stored in DB like this:
<link fileadmin/user_upload/pdf/10Ratgeber%20%2B%20Anleitungen/file.pdf _blank download "Leitet Herunterladen der Datei ein">Download</link>

When I edit the Content Element with the above mentioned link I get the attached Exception.

In my eyes this issue is caused by the whitespaces in the foldername. Renaming the dir to "10Ratgeber_Anleitungen" and editing the path manually with phpmyadmin solves the problem.


Files

exception.htm (28.2 KB) exception.htm Henrik Ziegenhain, 2013-03-04 11:53

Related issues

Related to TYPO3 Core - Bug #45490: Problem with blank spaces in data/folder namesClosed2013-02-14

Actions
#1

Updated by Henrik Ziegenhain over 9 years ago

Maybe related to #45490

#2

Updated by Henrik Ziegenhain over 9 years ago

The attached patch at #45490 from Marc Bastian Heinrichs solves this issue.

#3

Updated by Michael Stucki over 9 years ago

  • Status changed from New to Resolved

As this seems to be a duplicate of #45490, I am closing this issue.

#4

Updated by Benni Mack almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF