Bug #47106

Indexed search: index of external files not work on TYPO3 6.04

Added by Harald no-lastname-given over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-04-10
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hello!

I'm using TYPO3 6.04 for a new project. The search index is basically functioning properly. Only with the indexing of external files I have my problems. Files such as a PDF file will not be indexed. My basic installation is very simple and is proven (Window / Linux).

Only with the TYPO3 version 6.x does not indexing with external files. I will not take long to explain what I've configured everything, but I'm pretty sure there is something not in order. I can inform you that everything works fine with the same installation in the TYPO3 version 4.5 and 4.7. Perhaps it is also because of crawler.

I can not figure out unfortunately! It is perhaps possible that I have something in TYPO3 6.x certain renewals have not read carefully - - but I think it's more of a bug in the Index search program.

Please check it yourself. If I still might be wrong, I apologize.

Thank you so much

Harald

Sent along: sreenshot of error messages of the crawler

crawler-error-log.png View (23.3 KB) Harald no-lastname-given, 2013-04-10 21:08


Related issues

Related to TYPO3 Core - Bug #50562: Indexing Configurations not Working with crawler Resolved 2013-07-30

Associated revisions

Revision 41e5916d (diff)
Added by Wouter Wolters over 4 years ago

[BUGFIX] Indexing of external files does not work in indexed_search

After the namespace change a wrong replace was done in
indexed_search. Replace it with the correct class.

Change-Id: I35295f4fecde241ec3004a8ee6b7dd71d5e34e93
Resolves: #47106
Releases: 6.2, 6.1, 6.0
Reviewed-on: https://review.typo3.org/22595
Reviewed-by: Stefan Neufeind
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

Revision c75eefb8 (diff)
Added by Wouter Wolters over 4 years ago

[BUGFIX] Indexing of external files does not work in indexed_search

After the namespace change a wrong replace was done in
indexed_search. Replace it with the correct class.

Change-Id: I35295f4fecde241ec3004a8ee6b7dd71d5e34e93
Resolves: #47106
Releases: 6.2, 6.1, 6.0
Reviewed-on: https://review.typo3.org/22907
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

Revision d65c3604 (diff)
Added by Wouter Wolters over 4 years ago

[BUGFIX] Indexing of external files does not work in indexed_search

After the namespace change a wrong replace was done in
indexed_search. Replace it with the correct class.

Change-Id: I35295f4fecde241ec3004a8ee6b7dd71d5e34e93
Resolves: #47106
Releases: 6.2, 6.1, 6.0
Reviewed-on: https://review.typo3.org/22906
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

History

#1 Updated by Mikael Conley over 4 years ago

I have the exact same problem. Both on a version. 6.1.0. and the "old" 6.0.x.
We have two experienced TYPO3 integrators here that agree that everything is set up correct. Still we get the "Error: No Object" message in our crawler log and no indexing of files.

#2 Updated by Christian Kirchhoff over 4 years ago

Here is what I think causes the problem:
In file /typo3/sysext/indexed_search/Classes/Indexer, lines 799 and 811, there is this call:

$crawler->addQueueEntry_callBack(0, $params, 'EXT:indexed_search/class.crawler.php:&TYPO3\\CMS\\IndexedSearch\\Controller\\SearchFormController_files', $this->conf['id']);

That Controller named SearchFormController_files does not exist. In the former version it was tx_indexedsearch_files, so I guess there is a typo in the current version.

I exchanged the above lines with…

$crawler->addQueueEntry_callBack(0, $params, 'EXT:indexed_search/class.crawler.php:&tx_indexedsearch_files', $this->conf['id']);

…and now I get an "OK" when I try to index a file.

#3 Updated by Alban Cousinie over 4 years ago

I have met the same problem with Typo3 6.1.2 and 6.1.1

Everything has been configured super precisely by following step by step Xavier Perseguers tutorial frome here : http://xavier.perseguers.ch/tutoriels/typo3/articles/indexed-search-crawler.html

But I get the error displaying truncated in the crawler log :
Error: No object: EXT:indexed_search/class.crawler...

I could not find the complete error message in my website error log nor into typo3 error log. This makes debugging hard ! The error message should be displayed fully in the crawler log rather than truncated !

I tried to apply Christian's fix with greate expectations, unfortunately it didn't make the trick for me.

Obviously there misses a file SearchFormController_files in the Classes/Controller directory.

Also since Typo3 6.0, the class tx_indexedsearch_files has been renamed to CrawlerFilesHook, so the suggested fix above should now rather read :
$crawler->addQueueEntry_callBack(0, $params, 'EXT:indexed_search/class.crawler.php:&CrawlerFilesHook', $this->conf['id']);

Unfortunately for some reason it doesn't work either on my installation.

This is another thing broken in Typo3 6.0. I have met so many of these while doing my first Typo3 6.0 website. This new version is a real regression, this is a fact, despite of all the generous work done by open source developers. Recoding such important parts of the CMS while Typo3 NEOS is coming behind is a total nonsense and waste of time, while being dramatically bug prone.

So, starting from the begining, how to get the full error message ?

#4 Updated by Ketlin no-lastname-given over 4 years ago

Christian's fix is working for me. Controller named SearchFormController also reside in typo3temp/Cache/Code/cache_core/. So try to empty Cache catalog.

#5 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/22595

#6 Updated by Gerrit Code Review over 4 years ago

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/22906

#7 Updated by Gerrit Code Review over 4 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/22907

#8 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/22907

#9 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/22906

#10 Updated by Wouter Wolters over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF