Bug #47357

Extension Manager

Added by Steffen Liebig over 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
-
Start date:
2013-04-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Trying to install extensions under 6.0.x, I got the following mistake:

The auto-installation after downloading fails plus empty entries in LocalConf.php. EM doesn't show the extension list either. Re-starting EM and manual installation attempts result in this:

Under 6.0.1, I got everything installed after several tries, while installation under 6.0.4 completely fails. De-installation seems to work, but Re-installation under 6.0.1 completely fails as well. Strange: "full" entry in extArray at LocalConf.php for news system even when it's de-installed (no other attempts, this was strange enough ;-) )!

The message in my log which led to refused installations is this:

Core: Error handler (BE): PHP Warning: Invalid argument supplied for foreach() in
/home/www/typo3_6.0.4/typo3/sysext/extensionmanager/Classes/Utility/DependencyUtility.php
line 145

-> first attempts where tt_address 2.2.3, tt_news 3.4.0 Beta and site crawler 3.5.0, but it seems to be a general problem since other extensions failed too

Additionally under 6.0.1, while the green light of another extension (bt_simplecontact) light was on and the extension worked, the entry in extArray was empty ! But the update to 2.6.2 I ran that evening showed no errors...it's still usable (and listed in the extList), but has an empty entry in the extArray
of LocalConfiguration.php.

#1

Updated by Philipp Gampe over 9 years ago

An empty entry in extArray is OK as this just means that the extensions does not have configurations options (or those have never been saved before). They stay after uninstalling the extension.

I just tried with TYPO3 CMS 6.0.2 and 6.0.3. All the the mentioned extensions could be installed.
However the EM seems to ignore any failures in line 182 of DependecyUtility.

At least I could install bt_simplecontact although it as a max version of 6.0.1.

#2

Updated by Susanne Moog almost 9 years ago

  • Status changed from New to Needs Feedback
  • Is Regression set to No

@Philipp: https://review.typo3.org/#/c/23673/1 for the TYPO3 version check problems

@Steffen: Taking Philipps explanation into account is there still a problem?

#3

Updated by Markus Klein over 8 years ago

  • Status changed from Needs Feedback to Closed

No feedback after 90 days

Also available in: Atom PDF