Bug #47575

header element is rendered in lib.stdheader for all cases

Added by Patrick Broens over 8 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Category:
Content Rendering
Target version:
Start date:
2013-04-25
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

According to the HTML5 spec the header element represents

a group of introductory or navigational aids. A header element typically contains the section’s heading (an h1–h6 element or an hgroup element), but can also contain other content, such as a table of contents, a search form, or any relevant logos.

First of all, the hgroup element has been removed from the specs.
Secondly, header is used to group elements. Currently the header element is used if there is any content in lib.stdheader, so for instance with a single hx. This is not desired because a single element is not a group.

Wrapping lib.stdheader with the header element should only occur when the date is added to the header.


Related issues

Related to TYPO3 Core - Bug #53305: HTML5 rendering of headers works only if a date is setClosed2013-11-04

Actions
#1

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20149

#2

Updated by Mathias Brodala over 8 years ago

Another issue which arises from the current structure: one cannot use header content elements within header and footer areas on the page.

#3

Updated by Ernesto Baschny about 8 years ago

The hgroup has been removed already in https://review.typo3.org/20147 (for 6.2.0alpha1).

#4

Updated by Gerrit Code Review about 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20149

#5

Updated by Patrick Broens about 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Riccardo De Contardi almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF