Bug #47692

Changing the page header results in cache clears of all pages in the same directory

Added by Klaus Hinum over 7 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2013-04-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When changing fields of the page header (e.g. title) using the tce (process_datamap function) in an own extension, all caches of the pages in the same directory are deleted. As we got hundreds of pages in the same directory, the process takes very long (up to two minutes).
Mysql logs the following queries for each page in the same folder
137 Query SELECT DISTINCT identifier FROM cf_cache_hash_tags WHERE cf_cache_hash_tags.tag = 'pageId_37382'
137 Query DELETE FROM cf_cache_hash_tags WHERE cf_cache_hash_tags.tag = 'pageId_37382'
137 Query SELECT DISTINCT identifier FROM cf_extbase_object_tags WHERE cf_extbase_object_tags.tag = 'pageId_37382'
137 Query DELETE FROM cf_extbase_object_tags WHERE cf_extbase_object_tags.tag = 'pageId_37382'
137 Query SELECT DISTINCT identifier FROM cf_cache_pages_tags WHERE cf_cache_pages_tags.tag = 'pageId_37382'
137 Query DELETE FROM cf_cache_pages_tags WHERE cf_cache_pages_tags.tag = 'pageId_37382'
137 Query SELECT DISTINCT identifier FROM cf_cache_pagesection_tags WHERE cf_cache_pagesection_tags.tag = 'pageId_37382'
137 Query DELETE FROM cf_cache_pagesection_tags WHERE cf_cache_pagesection_tags.tag = 'pageId_37382'
137 Query SELECT DISTINCT identifier FROM cf_cache_rootline_tags WHERE cf_cache_rootline_tags.tag = 'pageId_37382'
137 Query DELETE FROM cf_cache_rootline_tags WHERE cf_cache_rootline_tags.tag = 'pageId_37382'
137 Query SELECT DISTINCT identifier FROM cf_extbase_reflection_tags WHERE cf_extbase_reflection_tags.tag = 'pageId_37382'
137 Query DELETE FROM cf_extbase_reflection_tags WHERE cf_extbase_reflection_tags.tag = 'pageId_37382'
137 Query SELECT DISTINCT identifier FROM cf_extbase_typo3dbbackend_tablecolumns_tags WHERE cf_extbase_typo3dbbackend_tablecolumns_tags.tag = 'pageId_37382'
137 Query DELETE FROM cf_extbase_typo3dbbackend_tablecolumns_tags WHERE cf_extbase_typo3dbbackend_tablecolumns_tags.tag = 'pageId_37382'
137 Query SELECT DISTINCT identifier FROM cf_extbase_datamapfactory_datamap_tags WHERE cf_extbase_datamapfactory_datamap_tags.tag = 'pageId_37382'
137 Query DELETE FROM cf_extbase_datamapfactory_datamap_tags WHERE cf_extbase_datamapfactory_datamap_tags.tag = 'pageId_37382'

#1

Updated by Markus Klein over 6 years ago

  • Is Regression set to No

This is the intended behaviour (as it has always been). This is not an excuse, but I can't tell you at the moment why all siblings are cleared too, there was a good reason.

#2

Updated by Philipp Gampe over 6 years ago

  • Status changed from New to Needs Feedback

Please check your TSconfig for this page: clearCache_pageSiblingChildren
http://docs.typo3.org/typo3cms/TSconfigReference/PageTsconfig/TCEmain/Index.html

The cache is cleared because it most likely effects the rendering.

#3

Updated by Alexander Opitz over 6 years ago

This is done to get the menu updated on all pages down there. Else you will end up with different titles in the menu for a page on the sibling pages.

So, can we close this issue?

#4

Updated by Alexander Opitz almost 6 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF