Bug #47711

Required image for fields with radio buttons

Added by Jean-S├ębastien Gervais over 6 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Backend User Interface
Target version:
-
Start date:
2013-04-29
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Hello,

I'm not sure if this is the right project for this, I found a small annoyance in usability with radio buttons in the backend; actually, it's the required image that overlaps radio buttons making users unable to click directly on the radio button where the required images is (clicking on the label works, but no one thinks about it!)

When you only have two radio button, the hidden required image sits between the two, and does no harm at all. When you have more options (3, 4 or more) it overlaps an option.. that is due to the top:28% css rule along with a larger container (more options):

img.t3-TCEforms-reqImg {
display: block;
height: 16px;
left: 14px;
margin-right: 2px;
position: absolute;
top: 28%;
width: 16px;
z-index: 3000;
}

I'm having the same issue under IE8/IE9 and Firefox, from the TYPO3 4.5.x branch (haven't tested 6 yet)

(ticket recreated from #46947)


Related issues

Related to TYPO3 Core - Bug #43585: Radiobutton select difficult due to clear.gif Closed 2012-11-29

History

#1 Updated by Mathias Schreiber over 4 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Benjamin Kott
  • Is Regression set to No

Benni, this is irrelevant when you're done with the bootstrap stuff?

#2 Updated by Riccardo De Contardi over 4 years ago

  • Status changed from Needs Feedback to Closed

I close this issue as I think it is a duplicate of #43585

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF