Bug #48674

Only limited languages for frontend applications available

Added by Daniel Alder over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-05-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since the changes beneath, only languages from the limited list in t3lib_l10n_Locales will work in frontend applications (tslib_fe->readLLfile/initLLvars & TypoScriptFrontendController->readLLfile/initLLvars).

1. I want to use Indonesian for example -> not possible anymore
2. it is a breaking change -> how comes it that it was applied to a patch release

Example:
config.language = id
1 = TEXT
1 {
data = LLL:test/locallang.xliff
}

Original issue:
http://forge.typo3.org/issues/44099

Introduced in Typo3 4.6 with this changeset but also integrated in all other releases up to 6.1:
https://review.typo3.org/#/c/18276/2/typo3/sysext/cms/tslib/class.tslib_fe.php

I don't no exactly why it's introduced but since it breaks localization for several languages it's clearly a bug.


Related issues

Related to TYPO3 Core - Bug #44099: L10n fallback does not work for TS labelsClosedXavier Perseguers2012-12-18

Actions
#1

Updated by Helmut Hummel over 8 years ago

  • Status changed from New to Needs Feedback
  • Assignee deleted (Xavier Perseguers)

Daniel Alder wrote:

1. I want to use Indonesian for example > not possible anymore
Since the changes beneath, only languages from the limited list in t3lib_l10n_Locales will work in frontend applications (tslib_fe
>readLLfile/initLLvars & TypoScriptFrontendController->readLLfile/initLLvars).
I don't no exactly why it's introduced but since it breaks localization for several languages it's clearly a bug.

If you want to use your "own" languages, you have to provide them in configuation:

$GLOBALS['TYPO3_CONF_VARS']['SYS']['localization']['locales']['user']['id'] = 'Indonesian';

2. it is a breaking change -> how comes it that it was applied to a patch release

Obviously this fixed a bug (complete language fallback implementation), but had the side effect of breaking other undocumented behaviour (using "own" languages without registering them).
Sorry for any inconvenience!

Can you check if the above configuration (e.g. in localconf.php) fixes your problem?

#2

Updated by Daniel Alder over 8 years ago

Helmut Hummel wrote:

If you want to use your "own" languages, you have to provide them in configuation:

$GLOBALS['TYPO3_CONF_VARS']['SYS']['localization']['locales']['user']['id'] = 'Indonesian';

Can you check if the above configuration (e.g. in localconf.php) fixes your problem?

Thank you! this is working like expected ;) (sorry I overlooked this configuration!) So the problem is solved.

#3

Updated by Markus Klein over 8 years ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF