Bug #49329

Content caching with page data key not working

Added by Simon Schaufelberger over 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Caching
Target version:
-
Start date:
2013-06-21
Due date:
% Done:

0%

TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

This bug report is related to Feature #34307 where it's written that the following code is working but it's not:

cache.key = mycachedcontent_{page:id}
cache.key.insertData = 1

my cache identifier in the table "cf_cache_hash" looks like this:
"mycachedcontent_", the page id is missing.

{TSFE:sys_language_uid} is working fine.


Related issues

Related to TYPO3 Core - Bug #34299: stdWrap caching Closed 2012-02-26

History

#1 Updated by Wouter Wolters over 6 years ago

  • Status changed from New to Needs Feedback

Can you try this out with (page:uid}
Looks like page:id is not working and in TypoScript I found only references to uid

#2 Updated by Simon Schaufelberger over 6 years ago

oh of course it must be uid! in TSFE it's id ;)

can you please update the docs?

http://docs.typo3.org/typo3cms/TyposcriptReference/Functions/Cache/Index.html#cache-examples

#3 Updated by Alexander Opitz about 6 years ago

  • Status changed from Needs Feedback to Closed

From linked documentation:

5 = TEXT
5 {
  cache.key = mycurrenttimestamp_{page:uid}_{TSFE:sys_language_uid}
  cache.key.insertData = 1
}

This seams correct (or already fixed in the last short days).

Also available in: Atom PDF