Bug #49499

TypoScriptFrontendController->initLLvars issue

Added by Popy no-lastname-given about 9 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Localization
Target version:
-
Start date:
2013-06-28
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

(Every method I'll speak about are in TypoScriptFrontendController class)

Currently, >initLLvars is called from >getConfigArray, which is called from index_ts.php a few lines before ->settingLanguage.

Because of that and the fact that >initLLvars does not reinit ->languageDependencies before filling it can cause some issue, especially if english is not the default sys_language, when one uses >settingLanguage hooks to init language (instead of typoscript conditions)

For instance :
  • My website is French / English, and i'll visit the English version
  • initLLVars fills ->languageDependencies with 'fr'
  • ->settingLanguage hook properly sets the current language
  • as it have to, the hook calls >initLLVars again. Which does not empty >languageDependencies before adding nothing to it.

So, in this case, I end up with a ->languageDependencies = array('fr'), which results into french labels on my english website version.

Solutions are :
  • Move >initLLVars call somewhere in >settingLanguage (where it should belong, IMO). Problem here is that maybe >convPOSTCharset will have to be moved after the language init (it depends on >initLLvars because of charsets) so it could be difficult to test.
  • add "$this->languageDependencies = array()" at the beginning of ->initLLVars in order to ... init ll vars (what is what we should expect from it, no ?)

Related issues

Related to TYPO3 Core - Bug #59035: "[BUGFIX] Fix possible language handling issue" break formhandler ajax functionalityClosed2014-05-22

Actions
#1

Updated by Markus Klein about 9 years ago

Are you able to provide a patch?

#2

Updated by Popy no-lastname-given about 9 years ago

Yep. I just have to re-read the Git manual.

Should I provide multi-version patches ? (6.0, 6.1, trunk)

#3

Updated by Jigal van Hemert about 9 years ago

  • Category set to Localization

If the problem is present in master (6.2-dev) push a patch set for that version initially. Once it's merged the person who merged it will take care of the backports; unless you offer to help him/her and do the backports to earlier versions.

#4

Updated by Popy no-lastname-given almost 9 years ago

Patch submitted to review : https://review.typo3.org/23529
Sorry for the delay

#5

Updated by Gerrit Code Review almost 9 years ago

  • Status changed from New to Under Review

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/23529

#6

Updated by Gerrit Code Review almost 9 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/23529

#7

Updated by Gerrit Code Review almost 9 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/23529

#8

Updated by Gerrit Code Review over 8 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/23529

#9

Updated by Gerrit Code Review over 8 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/23529

#10

Updated by Gerrit Code Review over 8 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/23529

#11

Updated by Gerrit Code Review over 8 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/23529

#12

Updated by Gerrit Code Review over 8 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/23529

#13

Updated by Markus Klein over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#14

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27664

#15

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_6-0 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27665

#16

Updated by Markus Klein over 8 years ago

  • Status changed from Under Review to Resolved
#17

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF