Bug #49794

Filelist module broken

Added by Martin Borer about 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2013-07-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Current master branch breaks the filelist module on windows.

Tested with a clean installation of current master branch (Typo3 6.2 ) / PHP 5.4 / Windows.

After installation and clicking Filelist and user_upload folder for example, following error will be thrown:

File /\/user_upload/index.html is not valid (".." and "//" is not allowed in path).

#1

Updated by Markus Klein about 8 years ago

  • Target version changed from next-patchlevel to 6.2.0

Are you getting this error via an Exception?
If so, can you please also paste the stacktrace here?

(Please enable displayErrors = 1, if not already done.)

Thank you

#2

Updated by Martin Borer about 8 years ago

Uncaught TYPO3 Exception
#1320286857: File /\/user_upload/index.html is not valid (".." and "//" is not allowed in path). (More information)

TYPO3\CMS\Core\Resource\Exception\InvalidPathException thrown in file
C:\www4\t3_master\typo3\sysext\core\Classes\Resource\Driver\LocalDriver.php in line 966.

8 TYPO3\CMS\Core\Resource\Driver\LocalDriver::checkFilePath("/\/user_upload/index.html")

C:\www4\t3_master\typo3\sysext\core\Classes\Resource\Driver\LocalDriver.php:

00222:  public function getFileInfoByIdentifier($fileIdentifier) {
00223:   // Makes sure the Path given as parameter is valid

00224:   $this->checkFilePath($fileIdentifier);

00225:   $dirPath = \TYPO3\CMS\Core\Utility\GeneralUtility::fixWindowsFilePath(
00226:    PathUtility::dirname($fileIdentifier)

7 TYPO3\CMS\Core\Resource\Driver\LocalDriver::getFileInfoByIdentifier("/\/user_upload/index.html")

C:\www4\t3_master\typo3\sysext\core\Classes\Resource\Driver\AbstractDriver.php:

00402:    throw new \TYPO3\CMS\Core\Resource\Exception\FileDoesNotExistException();
00403:   }

00404:   $fileInfo = $this->getFileInfoByIdentifier($identifier);

00405:   $fileObject = $this->getFileObject($fileInfo);
00406:   return $fileObject;

6 TYPO3\CMS\Core\Resource\Driver\AbstractDriver::getFile("/\/user_upload/index.html")

C:\www4\t3_master\typo3\sysext\core\Classes\Resource\ResourceStorage.php:

00799:   */
00800:  public function getFile($identifier) {

00801:   return $this->driver->getFile($identifier);

00802:  }
00803: 

5 TYPO3\CMS\Core\Resource\ResourceStorage::getFile("/\/user_upload/index.html")

C:\www4\t3_master\typo3\sysext\filelist\Classes\FileList.php:

00291:     $filesToSort = array();
00292:     foreach ($files as $file) {

00293:      $fileObject = $storage->getFile($file['identifier']);

00294:      switch ($this->sort) {
00295:       case 'size':

4 TYPO3\CMS\Filelist\FileList::getTable("fileext,tstamp,size,rw,_REF_")

C:\www4\t3_master\typo3\sysext\filelist\Classes\FileList.php:

00199:   */
00200:  public function generateList() {

00201:   $this->HTMLcode .= $this->getTable('fileext,tstamp,size,rw,_REF_');

00202:  }
00203: 

3 TYPO3\CMS\Filelist\FileList::generateList()

C:\www4\t3_master\typo3\sysext\filelist\Classes\Controller\FileListController.php:

00296:    $this->filelist->start($this->folderObject, $this->pointer, $this->MOD_SETTINGS['sort'], $this->MOD_SETTINGS['reverse'], $this->MOD_SETTINGS['clipBoard'], $this->MOD_SETTINGS['bigControlPanel']);
00297:    // Generate the list

00298:    $this->filelist->generateList();

00299:    // Set top JavaScript:
00300:    $this->doc->JScode = $this->doc->wrapScriptTags('

2 TYPO3\CMS\Filelist\Controller\FileListController::main()

C:\www4\t3_master\typo3\sysext\filelist\mod1\index.php:

00044: $SOBE = \TYPO3\CMS\Core\Utility\GeneralUtility::makeInstance('TYPO3\\CMS\\Filelist\\Controller\\FileListController');
00045: $SOBE->init();

00046: $SOBE->main();

00047: $SOBE->printContent();
00048: ?>

1 require("C:\www4\t3_master\typo3\sysext\filelist\mod1\index.php")

C:\www4\t3_master\typo3\mod.php:

00039:  require $temp_path . 'conf.php';
00040:  $BACK_PATH = '';

00041:  require $temp_path . 'index.php';

00042:  $isDispatched = TRUE;
00043: } else {
#3

Updated by Martin Borer about 8 years ago

Can someone confirm this issue?
Or is this 'only' a wrong configuration on my side or something like this?

I'm using XAMPP on Windows:
Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7

#4

Updated by Martin Borer about 8 years ago

Issue still alive with current master branch. Am I the only one with this Problem?

#5

Updated by Martin Borer about 8 years ago

  • Assignee set to Andreas Wolf

Hi Andreas,

Is it possible, that your commit https://review.typo3.org/#/c/17881/ has broken the Filelist Module on Windows? If yes, do you have an idea where the problem could be?

#6

Updated by Kim Lang about 8 years ago

Martin Borer wrote:

Issue still alive with current master branch. Am I the only one with this Problem?

Confirm!

TYPO3.CMS 6.2
Windows 8
XAMPP 1.7.7
PHP Version 5.3.8

#1320286857: File /\/Downloads/Hemd-Presenterhand-Logo1280x480.jpg is not valid (".." and "//" is not allowed in path). (More information)

TYPO3\CMS\Core\Resource\Exception\InvalidPathException thrown in file
E:\xampp\htdocs\typo3_src\TYPO3.CMS.GIT-master\typo3\sysext\core\Classes\Resource\Driver\LocalDriver.php in line 966.
#7

Updated by Ernesto Baschny about 8 years ago

  • Category set to File Abstraction Layer (FAL)
  • Assignee deleted (Andreas Wolf)
#8

Updated by Ute Winter about 8 years ago

Can confirm too!
Government package 6.2alpha1 with update to 6.2alpha2
on WindowsSystem (Typo36.0package with Apache2 and php5.3.5)

If you try to upload a file with context menu in file tree,
upload works fine and then content of folder shows up.(but only then!)

Same problem is Text with Image: Adding a Image:
in the PopUpWindow you see this:
Uncaught TYPO3 Exception
#1320286857: File /\/content_uploads/IMG_1402.jpg is not valid (".." and "//" is not allowed in path). (More information)

TYPO3\CMS\Core\Resource\Exception\InvalidPathException thrown in file
... \sysext\core\Classes\Resource\Driver\LocalDriver.php in line 966.

#9

Updated by Nicole Cordes about 8 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Nicole Cordes
  • Priority changed from Must have to Should have

Breaking patch was https://review.typo3.org/#/c/22078/ which is reverted already. I can't reproduce the error any more. Please confirm for closing this issue.

#10

Updated by Martin Borer about 8 years ago

Nicole Cordes wrote:

Breaking patch was https://review.typo3.org/#/c/22078/ which is reverted already. I can't reproduce the error any more. Please confirm for closing this issue.

Yes the error is gone now. you can close this issue!

#11

Updated by Wouter Wolters about 8 years ago

  • Status changed from Needs Feedback to Closed

Thanks for reporting back. Closed

Also available in: Atom PDF