Bug #50493

"Invalid Memcache->connection member variable" in unit tests

Added by Kasper Ligaard over 7 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Category:
Tests
Target version:
-
Start date:
2013-07-27
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Since [FEATURE] Add PHPUnit error handler as default (https://review.typo3.org/22456) was merged I have seen a lot of Core tests fail as errors with the text:

Memcache::get() [<a href='memcache.get'>memcache.get</a>]: Invalid Memcache-&gt;connection member variable

I do not think it is the PHPUnit feature which broke something. Rather it seems the feature surfaced some problem with the MemcachedBackend.

The error is located in the file TYPO3.CMS/typo3/sysext/core/Classes/Cache/Backend/MemcachedBackend.php in the two methods get() (line 239) and findIdentifiersByTag() (line 284).

I am not familiar with the Cache Framework and Memcached, so have no clue what might be wrong.

#1

Updated by Mathias Schreiber about 6 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Christian Kuhn
  • Is Regression set to No

@Christian:
Should this turn up in the current tests or is there some other magic involved?

#2

Updated by Christian Kuhn over 5 years ago

no idea - needs investigation.

#3

Updated by Alexander Opitz over 5 years ago

  • Category set to Tests
  • Status changed from Needs Feedback to New
#4

Updated by Christian Kuhn almost 5 years ago

  • Status changed from New to Closed

Mmm, the MemcachedBackend tests check for loaded memcache or memcached module and try to fsockopen() to 11211 on localhost within each setUp() to see if they can actually run the tests.

Maybe something is wrong with the local setup? At least I've never seen such warnings on my own, and also googling around doesn't reveal too much.

http://stackoverflow.com/questions/14217319/invalid-memcache-connection-member-variable-errors

https://twitter.com/markoheijnen/status/329988769719648256

Since this issue is open for 2 years now without anyone else mentioning a similar test error, I rather tend to close it for now. This one needs a local debug session anyway.

Kasper, in case this is still reproducible for you, it would be great if you could add a new issue with some more information. The issue should be relatively easy to track down, the two classes to look at are MemcachedBackendTest and MemcachedBackend only. No further internal knowledge of the cache framework is needed.

Also available in: Atom PDF