Bug #50912

BackendUtility::viewOnClick() called with non-integer

Added by Oliver Hader over 6 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Miscellaneous
Target version:
-
Start date:
2013-08-08
Due date:
% Done:

100%

TYPO3 Version:
6.1
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The origin is in DatabaseRecordList::makeControl() that tries to create a preview link with the page id "243#33163" - more strict checks will deny this request because it's not the expected integer value. Thus, BackendUtility::viewOnClick() is called with a string instead of an integer. This happens in the regular list module in the TYPO3 backend.

It's not critical if hooks and further processors use intval() on the argument, but is bad if methods expect the defined integer value.

Associated revisions

Revision b7bdd841 (diff)
Added by Oliver Hader about 6 years ago

[BUGFIX] BackendUtility::viewOnClick() called with non-integer

The origin is in DatabaseRecordList::makeControl() that
tries to create a preview link with the page id "243#33163"
- more strict checks will deny this request because it's not
the expected integer value. Thus, BackendUtility::viewOnClick()
is called with a string instead of an integer.
This happens in the regular list module in the TYPO3 backend.
It's not critical if hooks and further processors use intval() on the
argument, but is bad if methods expect the defined integer value.

Change-Id: Ib66c1ee219b67e51d534f11fbf1eaa330476ca93
Fixes: #50912
Releases: 4.5, 6.0, 6.1, 6.2
Reviewed-on: https://review.typo3.org/22951
Reviewed-by: Sascha Egerer
Tested-by: Sascha Egerer
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

Revision 9b4462ba (diff)
Added by Oliver Hader about 6 years ago

[BUGFIX] BackendUtility::viewOnClick() called with non-integer

The origin is in DatabaseRecordList::makeControl() that
tries to create a preview link with the page id "243#33163"
- more strict checks will deny this request because it's not
the expected integer value. Thus, BackendUtility::viewOnClick()
is called with a string instead of an integer.
This happens in the regular list module in the TYPO3 backend.
It's not critical if hooks and further processors use intval() on the
argument, but is bad if methods expect the defined integer value.

Change-Id: Ib66c1ee219b67e51d534f11fbf1eaa330476ca93
Fixes: #50912
Releases: 4.5, 6.0, 6.1, 6.2
Reviewed-on: https://review.typo3.org/23064
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision 5faa4da9 (diff)
Added by Oliver Hader about 6 years ago

[BUGFIX] BackendUtility::viewOnClick() called with non-integer

The origin is in DatabaseRecordList::makeControl() that
tries to create a preview link with the page id "243#33163"
- more strict checks will deny this request because it's not
the expected integer value. Thus, BackendUtility::viewOnClick()
is called with a string instead of an integer.
This happens in the regular list module in the TYPO3 backend.
It's not critical if hooks and further processors use intval() on the
argument, but is bad if methods expect the defined integer value.

Change-Id: Ib66c1ee219b67e51d534f11fbf1eaa330476ca93
Fixes: #50912
Releases: 4.5, 6.0, 6.1, 6.2
Reviewed-on: https://review.typo3.org/24594
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

History

#1 Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/22951

#2 Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/22951

#3 Updated by Gerrit Code Review over 6 years ago

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/23064

#4 Updated by Sascha Egerer about 6 years ago

I don't understand the problem. Could you please add a testplan for that?

#5 Updated by Oliver Hader about 6 years ago

  • Is Regression set to No

True... that happened in combination with other patches...
The origin is that BackendUtility::viewOnClick('123#456', ...) is called instead of having a uid in the first argument.

#6 Updated by Oliver Hader about 6 years ago

  • Subject changed from Exception on listing content elements in workspaces to BackendUtility::viewOnClick() called with non-integer

#7 Updated by Gerrit Code Review about 6 years ago

Patch set 2 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/23064

#8 Updated by Gerrit Code Review about 6 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/22951

#9 Updated by Gerrit Code Review about 6 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/22951

#10 Updated by Oliver Hader about 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#11 Updated by Gerrit Code Review about 6 years ago

  • Status changed from Resolved to Under Review

Patch set 3 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/23064

#12 Updated by Gerrit Code Review about 6 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/24594

#13 Updated by Oliver Hader about 6 years ago

  • Status changed from Under Review to Resolved

#14 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF