Feature #51271

Reportsmodule add test for Bug in LibXML

Added by Kay Strobach over 6 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Install Tool
Target version:
Start date:
2013-08-22
Due date:
% Done:

100%

PHP Version:
Tags:
Complexity:
no-brainer
Sprint Focus:

Description

Some scary host have problems saving ">><<" in a flexform.

To fix this we have an option in the installtool.

Installtool:
[BE][flexformForceCDATA] = 0

http://www.npostnik.de/typo3/extbase-controlleraction-per-flexform-konfigurierbar-machen/#comment-7052

To avoid frustration this should be checked either in the installtool or in the reports module.


Related issues

Related to TYPO3 Core - Task #49162: Rewrite install tool Closed 2011-10-30
Related to TYPO3 Core - Feature #51454: Install tool configuration system Closed 2013-08-28

Associated revisions

Revision 51ebe1cf (diff)
Added by Tomita Militaru almost 6 years ago

[TASK] Check for libxml bug in install tool

Add check for libxml bug when saving special characters ">><<"
in a flexform

Resolves: #51271
Releases: 6.2
Change-Id: I5d120cdfeb9538209273c8761d017cb67256617b
Reviewed-on: https://review.typo3.org/25089
Reviewed-by: Markus Klein
Tested-by: Markus Klein
Reviewed-by: Oliver Klee
Reviewed-by: Stefan Neufeind
Tested-by: Stefan Neufeind

History

#1 Updated by Kay Strobach over 6 years ago

a text could possibly use these two functions:

array2xml
https://typo3.org/api/typo3cms/class_t_y_p_o3_1_1_c_m_s_1_1_core_1_1_utility_1_1_general_utility.html#ab8631dc310e0931c0abe834f93bfbc42

xml2array()
https://typo3.org/api/typo3cms/class_t_y_p_o3_1_1_c_m_s_1_1_core_1_1_utility_1_1_general_utility.html#a356257d16679b49c2338e85e5d6d0eb8

using them with

array -> array2xml -> xml2array -> check if both arrays are the same

Should show wether the problem is present or not :D

#2 Updated by Ernesto Baschny about 6 years ago

  • Status changed from New to Accepted
  • Assignee deleted (Christian Kuhn)

Good idea, having this additional check could indeed be helpful! Could you provide a patch for it before beta2?

#3 Updated by Gerrit Code Review about 6 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/25089

#4 Updated by Gerrit Code Review about 6 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/25089

#5 Updated by Gerrit Code Review about 6 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/25089

#6 Updated by Gerrit Code Review about 6 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/25089

#7 Updated by Gerrit Code Review about 6 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/25089

#8 Updated by Gerrit Code Review about 6 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25089

#9 Updated by Gerrit Code Review about 6 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25089

#10 Updated by Gerrit Code Review about 6 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25089

#11 Updated by Gerrit Code Review about 6 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25089

#12 Updated by Gerrit Code Review almost 6 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25089

#13 Updated by Tomita Militaru almost 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#14 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF