Bug #51540

Check for host before connect to database

Added by Nicole Cordes about 7 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Install Tool
Target version:
Start date:
2013-08-29
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

On Windows system a database connection with an empty host is possible and a link is returned. We have to add a check for empty hostname otherwise an installation of TYPO3 isn't possible.


Related issues

Related to TYPO3 Core - Task #49162: Rewrite install tool Closed 2011-10-30
Related to TYPO3 Core - Bug #51956: Install Tool does not ask for database settings Closed 2013-09-12
Duplicates TYPO3 Core - Bug #51433: Install tool: Refactor database connect configuration settings Closed 2013-08-28

Associated revisions

Revision 0d2a39b6 (diff)
Added by Nicole Cordes about 7 years ago

[BUGFIX] Install tool uses empty database settings

Some systems allow to connect with empty username / password
configuration to the database. Although this is not wrong the install
tool should always ask for database credentials for new installations.
This patch prevents the install tool from setting an empty username and
password as default values without manually submitting the form.

Resolves: #51540
Resolves: #51956
Releases: 6.2
Change-Id: Ic245635bf649f4ad477d793eda658096ed659aa0
Reviewed-on: https://review.typo3.org/23866
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn
Reviewed-by: Markus Klein
Tested-by: Markus Klein

History

#1 Updated by Nicole Cordes about 7 years ago

An empty string is taken as 'localhost'.

#2 Updated by Christian Kuhn about 7 years ago

This is probably solved with the pending patch for #51433

#3 Updated by Christian Kuhn about 7 years ago

  • Status changed from New to Closed

closed as dupe for now.

#4 Updated by Gerrit Code Review about 7 years ago

  • Status changed from Closed to Under Review

Patch set 8 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/23394

#5 Updated by Christian Kuhn about 7 years ago

  • Status changed from Under Review to Closed
  • Is Regression set to No

#6 Updated by Nicole Cordes about 7 years ago

  • Status changed from Closed to Accepted

Tested current master with a standard xampp on Windows. Still same behaviour. But instead of checking for an empty host IMHO it's better to tune the install wizard

#7 Updated by Gerrit Code Review about 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/23866

#8 Updated by Gerrit Code Review about 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/23866

#9 Updated by Gerrit Code Review about 7 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/23866

#10 Updated by Nicole Cordes about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#11 Updated by Riccardo De Contardi almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF