Project

General

Profile

Actions

Bug #51585

closed

Missing required argument in EM List view

Added by Francois Suter almost 11 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Category:
Extension Manager
Target version:
Start date:
2013-08-30
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
no-brainer
Is Regression:
No
Sprint Focus:

Description

With #50234 the possibility to click on an extension's title to access the configuration was added to the Extension Manager's list view. Unfortunately the patch was backported as is to 6.0 and 6.1, but relied on a new feature of 6.2. There's a "uri" argument missing in the BE buttons icon view helper, crashing the EM's list view.


Files


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Task #50234: Usability: In the EM, make the extension titles links to the configurationClosedNicole Cordes2013-07-20

Actions
Has duplicate TYPO3 Core - Bug #51472: Extension Manager No ACCESS - Required argument "uri" was not suppliedClosed2013-08-28

Actions
Actions #1

Updated by Gerrit Code Review almost 11 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/23493

Actions #2

Updated by Gerrit Code Review almost 11 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/23494

Actions #3

Updated by Francois Suter almost 11 years ago

  • Target version changed from 2463 to next-patchlevel
Actions #4

Updated by Francois Suter almost 11 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #5

Updated by Achim Fritz over 10 years ago

an empty uri works not for TYPO3_6-0-10, the uri should point to
action:'showConfigurationForm',controller:'Configuration' (Attachment)

Actions #6

Updated by Francois Suter over 10 years ago

  • Is Regression set to No

It works for me. Sorry to answer with a silly question, but have you cleared all the cache?

Actions #7

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF