Project

General

Profile

Actions

Bug #52133

closed

Display title of related record when using fields of type:inline as TCA label

Added by Benjamin Rau almost 11 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2013-09-19
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
5.4
Tags:
Complexity:
no-brainer
Is Regression:
No
Sprint Focus:

Description

If you want to use an inline field (1:1 relation) as label for your TCA table the UID of related record is shown as value, but it is expected to use the TCA label from the related table.

Reason why this is not shown:
TYPO3\CMS\Backend\Utility\BackendUtility::getProcessedValue() is used to get value that is used for the TCA label.

This one contains a switch which handles some field types differently, for example selects with foreign_table or group fields from internal_type db.

Suggested solution:
There is simply missing a case for fields of type:inline. Just handle it like value is processed for fields of type select.


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #59656: List mode doesn't show relation number, but tries to get record title from related tableClosed2014-06-18

Actions
Related to TYPO3 Core - Bug #22970: t3lib_BEfunc::getProcessedValue() did not handle TCA type inlineRejected2010-06-23

Actions
Actions #1

Updated by Gerrit Code Review almost 11 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/23902

Actions #2

Updated by Gerrit Code Review almost 11 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/23902

Actions #3

Updated by Gerrit Code Review almost 11 years ago

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/23911

Actions #4

Updated by Gerrit Code Review almost 11 years ago

Patch set 2 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/23911

Actions #5

Updated by Gerrit Code Review almost 11 years ago

Patch set 3 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/23911

Actions #6

Updated by Anonymous almost 11 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #7

Updated by Gerrit Code Review almost 11 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/23912

Actions #8

Updated by Gerrit Code Review almost 11 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/23913

Actions #9

Updated by Gerrit Code Review almost 11 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at https://review.typo3.org/23914

Actions #10

Updated by Anonymous over 10 years ago

  • Status changed from Under Review to Resolved
Actions #11

Updated by Caspar Stuebs about 10 years ago

This fix in uncomplete.

To handle TCA type inline, some more lines of code are needed.

Please see Ticket #22970 - Patch is submitted to gerrit since 9 month

Actions #12

Updated by Benni Mack almost 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF