Bug #59656

List mode doesn't show relation number, but tries to get record title from related table

Added by Viktor Livakivskyi over 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2014-06-18
Due date:
% Done:

0%

TYPO3 Version:
6.1
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,

This issue is a regression, caused by fix of http://forge.typo3.org/issues/52133
Whenever an editor has detailed view of a table in "List" mode and selects columns, that are of type "inline" in TCA, he expects to see number of relations, like it was always before (or, at best - titles of each relation, but this was never implemented), but after fix of #52113 he sees title of record from related table.
The probelm is in fact, that "inline" fields store number of relations (e.g. 6), and that fix fetches record from related table by uid (which will be 6). As result, editor sees either [6!] or title of record with uid=6 instead of number of relations.

I'm not sure, if it is really regression or it is a bug of BackendUtility::getProcessedValue(), but it exists.

TYPO3 6.1.7 and below work correctly, 6.1.8 and above - have this bug.
Not sure about TYPO3 CMS 6.2 though...


Related issues

Related to TYPO3 Core - Bug #52133: Display title of related record when using fields of type:inline as TCA label Closed 2013-09-19
Related to TYPO3 Core - Bug #22970: t3lib_BEfunc::getProcessedValue() did not handle TCA type inline Rejected 2010-06-23

History

#1 Updated by Caspar Stuebs over 5 years ago

The fix of #52133 in uncomplete.

To handle TCA type inline, some more lines of code are needed.

Please see Ticket #22970 - Patch is submitted to gerrit since 9 month

#2 Updated by Wouter Wolters almost 5 years ago

  • Status changed from New to Needs Feedback

Hi,

Is this still an issue in newer versions of TYPO3 CMS (6.2.9)?
If yes, can you provide a newer patch against master by using Gerrit? http://wiki.typo3.org/CWT

#3 Updated by Viktor Livakivskyi over 4 years ago

Hi, Wouter.

Just checked it unde4r TYPO3 6.2.9 - this is no longer an issue.

#4 Updated by Riccardo De Contardi over 4 years ago

  • Status changed from Needs Feedback to Closed

Closed on request of the reporter.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF