Bug #52833

TS parse: saving a non-accessible results in JS error

Added by Philipp Gampe over 7 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
TypoScript
Target version:
-
Start date:
2013-10-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

If you enable the automatic inclusion of include files in the TypoScript setup editor, you can save the content back to the files. If anything goes wrong, e.g. the file is not there anymore or not writeable, then the user will just get a JS error message without a hind about the actual error.

Implement user side error handling and a proper AJAX response in saving function.


Related issues

Related to TYPO3 Core - Bug #17090: wrong INCLUDE_TYPOSCRIPT does not output error messageClosed2007-03-07

Actions
Related to TYPO3 Core - Bug #52834: INCLUDE_TYPOSCRIPT on save does not write if destination-file does not existRejected2013-10-15

Actions
Related to TYPO3 Core - Bug #49602: Saving TS to ext. files with t3editor gives only a general error on write-errorRejected2013-07-02

Actions
#1

Updated by Mathias Schreiber about 6 years ago

  • Status changed from New to Closed

dupe of #49602

Also available in: Atom PDF