Project

General

Profile

Actions

Bug #52855

closed

ExtensionManagementUtility ignores "priority" flag in $EM_CONF

Added by aimcom no-lastname-given almost 11 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
Start date:
2013-10-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

You can configure the key "priority" in the $EM_CONF of an extension. According to the current TYPO3 documentation, "top" and "bottom" and "" are allowed values for this field. The documentation says:

This tells the EM to try to put the extensions as the very first in the list.

(see http://docs.typo3.org/typo3cms/CoreApiReference/ExtensionArchitecture/DeclarationFile/Index.html)

I've tested this with a simple extension which is configured with "priority" => "top". In TYPO3 4.7, the extension manager installs the extension and inserts it at the beginning of $TYPO3_CONF_VARS['EXT']['extList']. In TYPO3 6.1, the extension management utility puts the newly installed extension at the end of ['EXT']['extListArray'] in the LocalConfiguration.php.

I think there is something wrong in \TYPO3\CMS\Core\Utility\ExtensionManagementUtility in the method loadExtension($extensionKey):

static public function loadExtension($extensionKey) {
    if (static::isLoaded($extensionKey)) {
        throw new \RuntimeException('Extension already loaded', 1342345486);
    }
    $extList = \TYPO3\CMS\Core\Utility\GeneralUtility::makeInstance('TYPO3\\CMS\\Core\\Configuration\\ConfigurationManager')->getLocalConfigurationValueByPath('EXT/extListArray');
    $extList[] = $extensionKey;
    static::writeNewExtensionList($extList);
}

It seems to me that the "priority" setting of an extension is simply ignored at the moment.


Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #51021: Priority ignored in 6+ EMClosed2013-08-12

Actions
Actions #1

Updated by aimcom no-lastname-given almost 11 years ago

Sorry, I haven't found this older bug entry (http://forge.typo3.org/issues/51021) on my first search attempts before I wrote this new entry... :\

Actions #2

Updated by Susanne Moog almost 10 years ago

  • Status changed from New to Closed

Hi,

thank your for your report. I'll close this one as duplicate, as you noticed yourself ;)

regards,

susi

Actions

Also available in: Atom PDF