Bug #51021

Priority ignored in 6+ EM

Added by Francois Suter over 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
Start date:
2013-08-12
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The priority flag is ignored by the TYPO3 CMS 6.0+ Extension Manager. Although seldom used it exists, is quite convenient and should be respected.

As a reminder, that flag may take values "top" or "bottom". A "top" extension should always be installed first, a "bottom" extension always last.


Related issues

Has duplicate TYPO3 Core - Bug #52855: ExtensionManagementUtility ignores "priority" flag in $EM_CONFClosed2013-10-15

Actions
#1

Updated by Andreas Kiessling about 8 years ago

I would not say, this is a seldomly used feature. gridelements e.g. uses this flag, so that the fields for the container column are added to all new content elements.
With the wrong load order, adding "new" content elements in a grid container fails (CTypes from extensions loaded after gridelements), because the needed field can not be set. So IMHO this needs to be tackled soon!

#2

Updated by Christian Kuhn almost 8 years ago

  • Is Regression set to No

See my comment on this to #51069, we don't need the priority stuff anymore as soon as dependencies are set up correctly.

#3

Updated by Susanne Moog over 7 years ago

  • Status changed from New to Closed

Hi,

I'm closing this one in favor of #51069 which covers the topic in more detail. Please give feedback there.

Thanks,

Susi

Also available in: Atom PDF