Bug #53275

Import of 4.* t3d exports to 6.* typo3: files do not work

Added by Sten _ about 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-11-01
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

As many others, I took the opportunity to do a clean move of the page data from 4.5 LTS to a 6.2 beta.

Importing of 4.* t3d forks so far, except if file are attached (an image in my usecase).

I get the following error:

#1300086584: uid of fileusage (sys_file_reference) has to be numeric. (More information)

InvalidArgumentException thrown in file
/home/sten/genoveva2_server/typo3_src-6.2.0beta1/typo3/sysext/core/Classes/Resource/ResourceFactory.php in line 548.

The stacktrace is here:

http://pastebin.com/Htfe1rjF

A clean import would be a great feature, since I am surely not the only one to do imports and exports between different LTS versions.

Best Reagrds


Related issues

Duplicates TYPO3 Core - Task #52593: Impexp: make 4.x exports work as import in 6.x Closed 2013-10-07

History

#1 Updated by Sten _ about 6 years ago

please close - duplucate of http://forge.typo3.org/issues/52593

#2 Updated by Wouter Wolters about 6 years ago

  • Status changed from New to Closed

Also available in: Atom PDF