Project

General

Profile

Actions

Bug #53795

closed

Fatal error on installing form sysext if caches are emtpy

Added by Markus Klein over 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Category:
Backend API
Target version:
Start date:
2013-11-20
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Clearing all caches with rm -rf typo3temp/Cache/* and trying to install the form sysext afterwards gives the following error

Fatal error: Class 'TYPO3\CMS\Form\Utility\FormUtility' not found in /.../typo3/sysext/form/ext_localconf.php on line 5

Steps to reproduce:
  1. Go to the extension manager and uninstall the form extension, leave the window as it is. (It shows only the form extension in the filtered extension list and the icon in front would install the ext again.)
  2. rm -rf typo3temp/Cache/*
  3. Click on the install-button now in the BE windows
  4. You'll get the error from above
  5. Click on the Extension Manager in the module frame to reload the module. (The extension list appears still filtered and form shows up as installed again.)

Don't know if it is an autoloading issue, but looks like the class loader is not up to date at this point in time.

Actions #1

Updated by Markus Klein about 10 years ago

  • Assignee set to Thomas Maroschik
Actions #2

Updated by Gerrit Code Review about 10 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27544

Actions #3

Updated by Thomas Maroschik about 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #4

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF