Project

General

Profile

Actions

Bug #53853

closed

Fatal error: Interface 't3lib_tceformsInlineHook' not found in ...

Added by Frans Saris over 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
Start date:
2013-11-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

With ext:news installed I get the following exception when I save a item in backend (any content item)

Fatal error: Interface 't3lib_tceformsInlineHook' not found in .../typo3conf/ext/news/Classes/Hooks/InlineElementHook.php on line 31

When I add the following line from LegacyClassesForIde.php to my ext_tables the interface fallback works.

interface t3lib_tceformsInlineHook extends \TYPO3\CMS\Backend\Form\Element\InlineElementHookInterface {}

I encountered this with ext:news but expect that more extensions that support the 4.* and 6.* branches will have this problem when implementing the old interfaces.


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #53855: Fatal error: Class 'Tx_Extbase_Utility_Extension' not found in ...typo3conf/ext/.../ext_localconf.phpClosed2013-11-22

Actions
Related to TYPO3 Core - Bug #54004: Extension checker does not use the autoloader?ClosedNicole Cordes2013-11-27

Actions
Actions #1

Updated by Markus Klein over 10 years ago

Looks like there's some php file not loaded?

Actions #2

Updated by Frans Saris over 10 years ago

I think the autoloader doesn't work on these usecases.

Actions #3

Updated by Wouter Wolters about 9 years ago

  • Status changed from New to Needs Feedback

Hi,

does the problem still exists within newer versions of TYPO3 CMS (6.2.9)?

Actions #4

Updated by Frans Saris about 9 years ago

  • Status changed from Needs Feedback to Resolved

Didn't encounter the problem anymore for a long time. So I guess we already fixed it :)

Actions #5

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF