Bug #55182

Epic #55070: Workpackages

Epic #55065: WP: Overall System Performance (Backend and Frontend)

Task #55179: Optimize SQL Performance

Speedup selection of storage

Added by Ingo Schmitt almost 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Performance
Target version:
Start date:
2014-01-20
Due date:
% Done:

100%

Estimated time:
2.00 h
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

the file storgae is selected by
SELECT * FROM sys_file_storage WHERE driver = 'S' AND sys_file_storage.deleted=N AND sys_file_storage.hidden=N AND sys_file_storage.deleted=N

Since there is no index on driver the query is executed without the query cache.

Solution add index in driver since there is already an index on hidden and deleted

History

#1 Updated by Ingo Schmitt over 5 years ago

  • Estimated time changed from 0.50 h to 2.00 h

#2 Updated by Ingo Schmitt over 5 years ago

SQL is no more present with current master. So Close

#3 Updated by Ingo Schmitt over 5 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF